Ask Your Question

Changing the default layout? [closed]

asked 2012-04-10 16:18:11 +0100

folding gravatar image

Right now LibreOffice starts in a format where you can open a big block of white surrounded by gray as if you're writing on a piece of paper against a gray desktop. I almost never use this format and want to just right into the format you see when you click "View - Web Layout" where the text fills up the LibreOffice window.

Is there a way to set this to default that way?

Thanks for any suggestions.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-08-22 22:23:36.068833


Is there at least a ticket for this option? Can't seem to find one. I find it very annoying as well. Version:

marckoby gravatar imagemarckoby ( 2014-08-25 12:05:55 +0100 )edit

You can suggest this enhancement at

Prince gravatar imagePrince ( 2016-09-26 11:52:33 +0100 )edit

I have filed this enhancement request as a bug:

Please check on it occasionally to confirm if it is still required because sometimes a bug is considered possibly solved by updates. You will know because a 'confirmation' comment gets attached to the bug.

eltimbalino gravatar imageeltimbalino ( 2016-10-19 06:15:02 +0100 )edit

5 Answers

Sort by » oldest newest most voted

answered 2012-04-10 20:48:00 +0100

luyu gravatar image

I don't know of any preset option in LO, but you can accomplish the same result this way.

Open Tools -> Options -> General and check "Enable experimental (unstable) features". Then go to Tools -> Macros -> Record Macro. Once you click on it, macro recording will start so make sure you do only what you want to be saved, that is clicking on View -> Web Layout and nothing but this. After that click the button "Stop Recording". Save the macro in My Macros -> Standard under the name WebLayout for example.

Now go to Tools -> Customize, click on Events tab and select LibreOffice in "Save In" box. In the events list select "New Document" and click on "Macro..." button. Now choose the macro you created under My Macros and click OK. Do the same for "Open Document" event. After you've finished with everything, click OK to exit Customize window.

The next time you create new or open existing document, view will automatically be set to Web Layout.

edit flag offensive delete link more


This workaround is not an option for those who don't want a Java Runtime Environment installed.

Like the comment from user "endolith" below, I found the template solution only works for new documents.

Existing documents always open in Print View, even if they were previously saved in Web View. As evidence of this, if I open an existing document and change it to Web View, the "File/Save" option will remain grayed out, indicating that attribute isn't stored as part of the document.

JOakly gravatar imageJOakly ( 2014-03-02 17:47:08 +0100 )edit

Good news: The above workaround works for me without installing Java Runtime Environment, because the web_view macro is already there: Macro Library > My Macros > Standard > Module1 > web_view

I'm running LO version

More details on the macro:

votermedia gravatar imagevotermedia ( 2017-11-16 06:31:16 +0100 )edit

answered 2012-07-15 15:50:14 +0100

Vincent Barbier gravatar image

To avoid using a Macro, you can follow those explainations (it's for openoffice, but it still works on libreoffice)

To put it short : 1) Open libreOffice (creates an empty document) 2) Switch to Web display (View > Web layout) 3) save as template (File > Templates > Save) 4) right clic your template's name in (File > Templates > Organise), and chose : "set as default template" 5) Close LibreOffice and restart : You should be in Web Display.

edit flag offensive delete link more


This works for creating new documents, and the layout is saved along with the file if it's .odt, but when you open a .doc file it always opens in Print layout. :/

endolith gravatar imageendolith ( 2012-11-29 16:00:25 +0100 )edit

answered 2015-05-22 16:17:04 +0100

I would also like this. None of the solutions suggested here work as well as just having an option to have Writer always default to Web Layout.

edit flag offensive delete link more

answered 2015-02-07 00:48:22 +0100

Completely agree that this is annoying.

I created a keyboard shortcut (I chose alt + shift + w) to toggle between "web layout" and "print layout".

To do it, go to the following:

Tools > Customize

then choose in the box that opens up the boxes

Category > View

then choose

Function > Web layout

and then

choose the keyboard shortcut of your choice from the box "Shortcut keys"


I don't understand why this view mode is called "Web layout" to begin with -- IMHO it should be called "Continuous view" or "Default view", with "Print view" being the secondary option.

edit flag offensive delete link more

answered 2015-07-05 19:33:53 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I found a solution here :

edit flag offensive delete link more

Question Tools



Asked: 2012-04-10 16:18:11 +0100

Seen: 9,797 times

Last updated: Jul 05 '15