Ask Your Question
0

calc, large numbers show as 2E+05 3E+05

asked 2019-02-26 23:36:47 +0100

icerabbit gravatar image

updated 2020-07-09 00:35:11 +0100

Alex Kemp gravatar image

I have an existing .ods file that I have been using for years and carrying forward through updates, adding some numbers and data as years go by.

Opening the file which I last saved spring / summer 2018, in one area of my calc file the six digit numbers are displayed as:

2E+05 3E+05 4E+05 etc

Something which I have never seen before.

When I click on any of those, the data entry box shows the correct 6 digit number 123456 234567 345678. When I check the formatting of that line, it has not been changed, it is just plain "number"

It seems to be only with 6 digit numbers. Those with 1 - 5 digits are fine.

Questions: How did this come about, suddenly 8-10 years in? and more importantly How do I fix this?

My current installed version is 5.4.6.2 (downloading 6+ in the background at the moment)

As it is a large spreadsheet the font is Arial 5 to get as much on screen as possible and avoiding ### but that is not what it is showing.

Is this "odd numbering scheme / number notation " a new way of saying whatever I have does not quite fit?

I tried to search google and some forums, did not come up with a solution; other than hints that this may be engineering notation.

Thanks in advance for any insights and solutions.

PS: can't share the file publicly, it is big and contains too much information that would have to be scrubbed out and anonymized.

edit retag flag offensive close merge delete

Comments

1

This is the scientific notation. Please see if this can help. You can remove all irrelevant information from copy of your file and upload this copy by editing your question.

SM_Riga gravatar imageSM_Riga ( 2019-02-27 06:33:42 +0100 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2019-02-27 06:40:48 +0100

gabix gravatar image

This means that Calc can't properly render the numbers to show them fit in the cell on the screen. Previously, you'd see those ###, now the behavior is changed for numbers. Try to:

a) simply zoom in;

b) increase column width;

c) changing the font. Since you're fond of Arial, try Arial Narrow, for example.

edit flag offensive delete link more

Comments

Yes, that is correct. While Calc can not fit general number in cell's width, but can fit scientific notation -scientific notation is used. When both options do not fit - ### is rendered.

SM_Riga gravatar imageSM_Riga ( 2019-02-27 08:52:08 +0100 )edit

Oops, SM_Riga, I see that in your comment you have provided a link to an exhaustive thread on the issue. It appears, I have only duplicated it. Thank you!

gabix gravatar imagegabix ( 2019-02-27 09:27:55 +0100 )edit

Oh no, the link I provided is about changing representation from scientific notation to general numbers, I didn't see column width issue mentioned there, so your answer is absolutely in place! @icerabbit mentioned

As it is a large spreadsheet the font is Arial 5 to get as much on screen as possible and avoiding ### but that is not what it is showing

so cell witdh now is obviously set very close to content's width and I believe you have pinpointed the problem's cause. Voted for your answer :)

SM_Riga gravatar imageSM_Riga ( 2019-02-27 10:04:55 +0100 )edit
0

answered 2019-02-27 13:49:15 +0100

icerabbit gravatar image

Thank you for the responses.

Mystery has been identified.

Fact remains though that this sheet was setup in the past, on libreoffice, on the same computer, same screen display, etc and everything sized just so for readability so that the whole sheet in landscape, even if there were six digits in a column, maybe drop it to Arial five for that row, but they would render properly on screen and in print. There physically is room for an extra digit in the front.

C:\fakepath\libreoffice 6 digit scientific.png

So, there appears to have been a change, somehow, at one point with the programming, where extra padding within the cell box is required?

From the looks of it, it seems there now needs one digit's worth of screen space in front and behind the actual number? Otherwise it goes scientific?

Unless I drop these to Arial Narrow 5 - thanks for the hint Gabix - ... I get scientific ... but now there certainly is room for two extra digits, visually ??

C:\fakepath\libreoffice 5 6 digit arial 5 narrow padding.png

That is a lot of padding that is required :(

edit flag offensive delete link more

Comments

there appears to have been a change

It looks like somewhere in the 6.x branch. I don't upgrade often and I don't process lots of spreadsheets, noticed this behavior only in 6.1.2 and not in 5.4.

gabix gravatar imagegabix ( 2019-02-27 14:25:50 +0100 )edit

I can confirm this "padding or it goes scientific notation" is present in LO 5.4.6 which I got on May 2018; and I just installed LO 6.2.0 on this am.

This desktop, I semi-intentionally have not updated it past OS X 10.12 as I did not see a benefit, computer runs great, etc but I do update LO from time to time.

The laptop gets updated daily, weekly

icerabbit gravatar imageicerabbit ( 2019-02-27 15:18:09 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-02-26 23:36:47 +0100

Seen: 1,734 times

Last updated: Feb 27 '19