Ask Your Question
0

Formatting paraghraphs and text continuity

asked 2019-02-27 10:24:26 +0200

libregrid gravatar image

Hello,

I am trying to copy and paste a website link into libre writer and this is driving me crazy. For some reason, when I past the website link into the document, there are always gaps within the link. I tried clearing direct formatting and I also pasted it without formatting but nothing works. For example, when I press the erase button before vid=3&....it begins to delete part of the text above it, namely the question mark (..detail?...). I just don't want there to be any gaps.

On top of that whenever I press the tab button, the gaps become larger and part of the links turns blue and is underlined and I can't change that either. I selected the text and tried to manually change the font color and to delete the underlines. Any input appreciated. Thanks.

image description

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2019-02-27 10:51:33 +0200

ajlittoz gravatar image

updated 2019-02-27 10:52:29 +0200

Without much technical information about your document, what you call "gaps" is an artifact caused by line wrapping algorithm in Writer. It has no impact on hyperlink internals.

The first gap appears after from on the first line because there is no space after "www." (end of sentence) Consequently what follows is considered a single word up to the next wrapping position candidate, i.e. space, some punctuation or special character like *? or =. This is why the second line is cut after ? (a legal known punctuation when dealing with pure text) and before = at the end of the third line (a non "word-component").

The problem is cause by the very long sequence of characters without "nominal" "wrapping points". LO Writer tries its best to fit this sequence in the available paragraph area, cutting the long sequence where it deems acceptable. It does not add any newline or paragraph break. Text just flows from one line to the next. This explains why Bksp just erases the preceding character without removing the wrapping.

The solution is either to reduce font size so that the link can be set in a single line, but I doubt this can be done while keeping readability considering the huge length of the link or to compose your document in landscape orientation, which will give it a queer aspect if you only have one or two such links.

The best solution is to insert the link with Insert>Hyperlink instead of pasting it directly. In the popped-up dialog, you paste the link and give it a short name which will be used instead of the URL. The short name will behave like the URL itself.

When you use the tab button (You didn't mention where, but I guess after www.), you create a space in such a location that URL recognition is triggered. LO Writer transforms text http://… into an active hyperlink and styles the correcponding sequence with character style Internet link (font color purple/deep blue, underline) to give a visual clue about the link.

If you don't like it, either right-click on the link and Remove Hyperlink or change Internet Link attributes.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Comments

Thanks for the comment. You seem very knowledgeable. I can't use the hyperlink because I need to copy and paste the complete link for citation purposes. It's also not allowed to be underlined.

I did create space after www. but that did not change anything. Also, it won't even let me adjust things with the space button to move text.

I used the tab button before www.

Sorry, but this is worse than Microsoft Office. Is there a way I can disable everything so that libre writer does not try to "help" me? I have the same problem typing all the links manually. This is such an unusual inconvenience. Usually I don't have these kind of issues with libre writer.

Thanks

libregrid gravatar imagelibregrid ( 2019-02-28 07:38:28 +0200 )edit

The problem is the huge length of the URL (without "natural" cutting points). Describe precisely the purpose of the information (you alluded citation purpose, but do you need it to be active: click and open browser ?).

Meanwhile, if the URL is considered simply text (no hyperlink), you can disable automatic recognition in Tools>AutoCorrect>AutoCorrect Options, Options tab.

ajlittoz gravatar imageajlittoz ( 2019-02-28 08:06:13 +0200 )edit

Hi, No, I don't need the link to be active. I just don't want LibreWriter to try to cut the long sequences. I don't want LibreWriter to do anything for me. I just want the text to continue without any attempts by LibreWriter to fit the long sequence into the available paragraph area. I just want the text to continue without being cut into pieces. I clicked on the AutoCorrect Options and disabled everything. It still tries to cut the long sequences. Thanks

libregrid gravatar imagelibregrid ( 2019-03-09 04:56:21 +0200 )edit

Whatever you try, the "monster" URL will not fit in a single line. Therefore, Writer tries to find either word breaks or hyphenation points in the string. Hyphenation is to be discarded because it adds hyphens when cutting and these hyphens are not present in the original URL.

Since your URL contains a "query string" (the part after ?), I suggest, you add spaces before, after or around &: & is an operator glueing together several var=value definitions. This will provide line wrapping points.

Spaces are not allowed in URL they act as terminators), consequently they don't matter to just display an URL. Strangely enough, I just noticed there are 2 spaces in the bdata= value. In principle, spaces are replaced by +. Where the spaces in the original link?

ajlittoz gravatar imageajlittoz ( 2019-03-09 07:52:49 +0200 )edit

No, the spaces where not in the original link. Thanks for all the input by I give up. This problem is so beyond ridiculous that I don't even know what to say. Programmers' mind can be very rigid.

libregrid gravatar imagelibregrid ( 2019-03-18 02:47:07 +0200 )edit

This is like the Boeing 737 Max 7 planes. The software tries too much to do too many things for the pilot to the point where it can't be corrected anymore. Catastrophe is the inevitable result.

libregrid gravatar imagelibregrid ( 2019-03-18 02:53:04 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-02-27 10:24:26 +0200

Seen: 48 times

Last updated: Feb 27