Ask Your Question
0

[Writer] Outline level for custom styles resets when document is closed [closed]

asked 2019-03-10 14:34:29 +0200

Ntilarrmm gravatar image

I'm editing a document that is sufficiently large as to be unmanageable without navigation headings.

Custom headings have been defined as per the publisher's requirements, and in the paragraph style box the outline level is set to the appropriate number (Level 1, 2, 3 etc). Everything works, and I use the headers for an entire editing session.

The problem is that when I reopen the document for the next session, all headings have disappeared from the Navigator and all custom headings have reset their outline levels back to "Body Text".

It doesn't take me long to change the levels back to what I want, but it's annoying and feels unnecessary. If anyone has any suggestions, I'd appreciate it!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Ntilarrmm
close date 2019-03-10 15:48:41.108484

Comments

Did you save your document as .odt or some other foreign format?

ajlittoz gravatar imageajlittoz ( 2019-03-10 14:51:20 +0200 )edit

It's saved as a Microsoft Word 97-2003 document

Ntilarrmm gravatar imageNtilarrmm ( 2019-03-10 14:52:41 +0200 )edit

Try saving it a the native format .odt. You should always save the document in this format.

petermau gravatar imagepetermau ( 2019-03-10 15:26:51 +0200 )edit

That fixed it, thanks!

Ntilarrmm gravatar imageNtilarrmm ( 2019-03-10 15:28:15 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-03-10 15:40:32 +0200

ajlittoz gravatar image

updated 2019-03-10 15:41:35 +0200

As far as I can remember, M$ Word is far less versatile than LO Writer when it comes to outline. In Writer, any paragraph style may be declared "outline" and will be collected in the TOC and Navigator. Apparently, in the conversion module only Heading n will be associated with .doc outline levels. Similarly, when importing, Word outlines are set to Writer Heading n only.

The lesson of the story, once more, is always save any document in native format for processing application. Only convert to foreign format after your work is copy-ready, anyway without guarantee it will be converted as intended.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2019-03-10 14:34:29 +0200

Seen: 173 times

Last updated: Mar 10