Clear formatting keeps reverting font to Liberation Mono instead default style Liberation Serif

asked 2019-03-11 15:56:10 +0100

ahiijny gravatar image

updated 2020-08-09 11:02:15 +0100

Alex Kemp gravatar image

Hi, ever since I pasted a line of text from an Adminer row listing into my odt document, Ctrl+M has been behaving strangely. I want Ctrl+M to change the text to the default style of Liberation Serif, but instead it's changing the font to Liberation Mono. It seems to happen sometimes when I paste text inside <code> tags.

Steps:

  1. Start a new document
  2. Copy some text inside <code> tags
  3. Paste it into the document

Observations:

  1. If I select the pasted text and press Ctrl+M, the formatting stays Liberation Mono
  2. Format > Clear Direct Formatting doesn't change anything
  3. Style box > Clear Formatting doesn't change anything
  4. Style box > Default Style doesn't change anything (it's already set to Default Style though)
  5. In the F11 Manage Styles sidebar, Default Style > Font shows that it should be Liberation Serif
  6. Any text I type in following paragraphs also have this problem.
  7. I can manually set the font to Liberation Serif, but Ctrl+M will change it back to Liberation Mono. Also, any new Heading 1, Heading 2, etc. that I insert are also Liberation Mono for some reason.

So tl;dr after I pasted the text, it's in a weird state where Ctrl+M doesn't revert text to the default style Liberation Serif. How do I get it back into a normal state?

Thanks.

edit retag flag offensive close merge delete

Comments

1

What is the character style of the text? Clear formatting removes direct formatting - but not styles, character styles among them.

Mike Kaganski gravatar imageMike Kaganski ( 2019-03-11 21:16:12 +0100 )edit