Ask Your Question
1

LibreOffice4 fails to open odt document but not OpenOffice [closed]

asked 2013-06-07 11:06:14 +0200

chrimi gravatar image

updated 2015-09-06 22:45:32 +0200

Alex Kemp gravatar image

I cannot open an .odt document with LO4 but I can do it with OpenOffice. If I save the document with OO then I can open it with LO. Is there a bug behind_

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by manj_k
close date 2014-03-17 21:23:35.319826

Comments

Reported as Bug 65521 - FILEOPEN: LibreOffice fails to open a .odt file, but OpenOffice does.

(Sample file in fdo#65521)

EDIT 2013-06-20
Status: RESOLVED WORKSFORME (v4.1.0)

manj_k gravatar imagemanj_k ( 2013-06-08 00:08:16 +0200 )edit
1

OK for closing the subject

chrimi gravatar imagechrimi ( 2013-06-18 10:15:25 +0200 )edit

Which in common language means the bug is fixed in 4.1 (which will be released by the end of July, with release candidates already available)

Pedro gravatar imagePedro ( 2013-06-20 15:07:19 +0200 )edit

I still have this bug in LibO 4.0.2, 4.1.5 and 4.2.1... Is it really fixed? Just crashes without error message, while OpenOffice can open it without complaining!

Edit: I'm using Linux Mint

panos gravatar imagepanos ( 2014-02-26 11:55:26 +0200 )edit

@panos, I can open the file included in the bug report without any problem. If the bug still occurs under Linux Mint using the same file then Reopen the bug. If you are having the same problem but with another file, then open a new bug report.

Pedro gravatar imagePedro ( 2014-02-26 13:13:17 +0200 )edit

I can open that file, too, so I guess it's a different variant of the same problem... I'll try to upload a version of my file. Also, is there a log file where I might an error message? I have already looked at ~/.xsession_error and couldn't find anything relevant.

panos gravatar imagepanos ( 2014-02-26 13:35:06 +0200 )edit

@panos, I have no idea :) Maybe some Linux user can help with that... Please create a new bug report at https://bugs.freedesktop.org/enter_bug.cgi?product=LibreOffice

Pedro gravatar imagePedro ( 2014-02-26 13:39:14 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2013-06-08 01:15:08 +0200

Pedro gravatar image

Apparently it was some regression in LibreOffice. It is already fixed in version 4.1 (you can get a working Beta today or wait for a Release Candidate in about two weeks)

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-06-07 11:06:14 +0200

Seen: 2,109 times

Last updated: Jun 20 '13