Ask Your Question
0

How to fix missing java problem in base

asked 2019-03-13 04:44:11 +0200

dougmn gravatar image

I just opened a database file that I had not opened for a few weeks, and got this message:

"The LibreOffice configuration has been changed. Under Tools - Options - LibreOffice - Advanced, select the Java runtime environment you want to have used by LibreOffice."

The path that's offered when I go to "Tools - Options - LibreOffice - Advanced" doesn't contain a Java runtime environment.

When I try to open any of the forms or reports, I get this message: The connection to the data source “DatabaseName” could not be established. No Java installation could be found. Please check your installation.

Writer is working okay. I use it all the time.

Here's my the info on my installation:

Version: 6.2.1.2
Build ID: libreoffice-6.2.1.2-snap1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3;
Locale: en-US (en_US.UTF-8); UI-Language: en-US

How do I fix this? Where can I find the lost JRE?

edit retag flag offensive close merge delete

Comments

ebot gravatar imageebot ( 2019-03-13 06:44:11 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-03-13 06:00:02 +0200

Ratslinger gravatar image

Hello,

Have never used snap versions so I don't understand why the configuration was reset.

First be certain on Advanced section at the top, Use a Java runtime environment is checked. If when checked nothing then appears in the window below it, proceed with finding Java install.

Java can be installed in a variety of different places in Linux systems depending upon the distro (you don't mention) the Java you have installed (Oracle, Open JDK) or if you just downloaded a version and extracted it to a directory of your choice (have done this a lot on Ubuntu systems). So the key is finding where yours is.

Based upon this post -> Where can I find the Java SDK in Linux? the method which best worked on my Mint 18.3 install was (using terminal):

cd /
sudo find . -name 'javac'

Once you find it you can add it under Advanced by pointing to the correct folder using the Add button on top right.

edit flag offensive delete link more

Comments

Okay fixed, by playing around a little bit. I had read this above from @Ratslinger more carefully, it would have been faster:

First be certain on Advanced section at the top, Use a Java runtime environment is checked. If when checked nothing then appears in the window below it, proceed with finding Java install.

"Use a Java runtime environment" was checked, but something DID appear in the window below. It listed a JRE from Oracle Corporation, but the little circle was unchecked. Clicking that little dot, then clicking "apply" at the bottom got it fixed.

I don't know how it got changed in the first place, but I'm glad it's fixed.

dougmn gravatar imagedougmn ( 2019-03-13 21:57:10 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-03-13 04:44:11 +0200

Seen: 81 times

Last updated: Mar 13