UK dictionary doesn't work

asked 2019-03-14 20:44:25 +0100

rikjwells gravatar image

I have written several documents without realising that I have had typing mistakes which had not been signalled by the automatic spelling check. I have set the default language to English (UK) and even explicitly set the document's "All text" language to the same and even intentional spelling mistakes are not signalled. Changing to US English works, though clearly the differences are not acceptable and distracting. I have "completely removed" libreoffice-writer and reinstalled to no effect, and even tried restarting in safe mode with no change so I deduce that the English (UK) library does not wor for some reason.

The documents include job applications and it's very embarrassing and possibly discounts me from consideration if I seem to be unable to check my documents!

I am using Ubuntu 18.10 (fully updated) with LibreOffice Version: 6.1.5.2 Build ID: 1:6.1.5-0ubuntu0.18.10.1 CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3; Locale: en-GB (en_US.UTF-8); Calc: group threaded

edit retag flag offensive close merge delete

Comments

Did you install the English(GB) Translated User Interface? http://download.documentfoundation.or...

petermau gravatar imagepetermau ( 2019-03-14 22:55:41 +0100 )edit

Usually Linux distro provide "language packs". Out-of-the box, LO is fitted with only US English. Full set of English variants is a separate package. You can tell that from the language drop-down menu: installed languages have a small icon with ABC and a check mark at left.

ajlittoz gravatar imageajlittoz ( 2019-03-15 08:04:27 +0100 )edit