Ask Your Question
0

Excess padding in single line table.

asked 2019-03-18 17:56:30 +0200

peterEG gravatar image

In a Writer table I can't remove extra vertical padding when the row only has a single line of text. I want the row to be the same height as when text is written outside a table. I have checked that the paragraph has zero spacing above and below. But if I select Optimal Row Height there is excess space above and below the text. If I add more text so that two lines are used there is no excess vertical spacing.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2019-03-18 19:04:58 +0200

ajlittoz gravatar image

When you're outside table, your paragraphs are styled Body Text (I know, Writer starts a fresh blank document in Default Style but you should always switch to Body Text. Anyway, it will automatically switch to Body Text after any Heading n; so, for consistency, you'd better style accordingly the paragraphs before the first Heading n.)

Inside tables, by default, paragraphs in cells are styles Table Contents.

Consequently, if you want same formatting in and out, you must harmonise both styles.

Another point to watch for is the amount of padding in case you defined borders. This padding is controlled from Table>Table properties, Borders tab, not from the paragraph styles since it adds extra space independent from the styles.

Lastly, Table>Size>Optimal row height is a convenient shortcut to check Fit to size in the Row height menu. This has no incidence on the paragraph style definitions.

Note: if paragraph spacing is the result of direct formatting, i.e. defined directly without going through paragraph style modification (forcing these spacings with Format>Paragraph), spacings are not reset when Optimal row height is applied. You need first to Format>Clear direct formatting.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more
0

answered 2019-03-21 12:57:02 +0200

peterEG gravatar image

Thanks for your help. I had missed the spacing below in Table Contents. I had just looked at the spacing in Table Properties, not the Table Contents style.

edit flag offensive delete link more

Comments

You're welcome. If you deem the answer valuable, please upvote it, you now have enough karma.

BTW, thanks and other compliments should go to a comment, not an answer, so that this is not considered as an alternative answer.

ajlittoz gravatar imageajlittoz ( 2019-03-21 15:07:59 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-03-18 17:56:30 +0200

Seen: 25 times

Last updated: Mar 21