Ask Your Question
0

Writer 6.1.5.2 - speller not using standard.dic

asked 2019-03-18 19:44:07 +0200

carnish gravatar image
 Version: 6.1.5.2
 Build ID: 1:6.1.5-0ubuntu0.18.10.1
 Locale en_ca

The spell check is marking errors for words that I have added to the dictionary and which are present in .../wordbook/standard.dic.

I've only noticed this today. There was an update to LO via the Ubuntu repository a few days ago, and perhaps that introduced this issue, but is there any configuration item I could check to verify. Perhaps it's just that something got knocked.

edit retag flag offensive close merge delete

Comments

1

Check "Tools -> Options -> Paths" type "Dictionaries". Does the path really point to your real standard.dic

Opaque gravatar imageOpaque ( 2019-03-18 20:03:25 +0200 )edit

@Opaque It points to the directory containing standard.dic, not to the file itself.

carnish gravatar imagecarnish ( 2019-03-18 20:27:51 +0200 )edit
1

Sorry, if being misleading. It is correct to point to the directory containing the file.

Opaque gravatar imageOpaque ( 2019-03-18 22:55:32 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-04-01 14:51:27 +0200

carnish gravatar image

updated 2019-04-01 14:53:03 +0200

The issue is resolved by changing the character language of the style to English US. It was set to English Canada.

This isn't a big deal for me because even though I'm Canadian I prefer US spelling nearly always -- the US date format a pariicular and exception to this rule.

edit flag offensive delete link more

Comments

Normally, standard.dic applies to all languages. Thus, the behavior in your case is a bit unusual. Anyway, you can change the standard.dic language via Tools → Options → Language settings → Writing Aids → Edit instead of changing the text language.

gabix gravatar imagegabix ( 2019-04-01 16:03:06 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-03-18 19:44:07 +0200

Seen: 73 times

Last updated: Apr 01 '19