Ask Your Question
0

What changed to stop the connection.

asked 2019-03-19 02:23:40 +0200

Bob Dale gravatar image

LibreOffice Version: 6.1.5.2 (x64) MySQL version 5.7.25 mysql-connector-java-8.0.15

The connection to the data source "MyDB" could not be established.

The server time zone value 'CDT' is unrecognized or represents more than one time zone. You must configure either the server or JDBC driver (via the serverTimezone configuration property) to use a more specifc time zone value if you want to utilize time zone support.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2019-03-19 03:10:32 +0200

Ratslinger gravatar image

Hello,

Don't remember what prompted the change (vaguely remember MySQL update) but just add:

?serverTimezone=America/Chicago

to the end of your JDBC Datasource string. I believe UTC with + or - hours also works.

Reference list -> List of tz database time zones

edit flag offensive delete link more

Comments

Datasource URL can be found from main Base menu Edit->Databese->Properties...

Ratslinger gravatar imageRatslinger ( 2019-03-20 04:44:50 +0200 )edit

Partly this is my fault for not asking which JDBC connection you are using - MySQL(JDBC) or JDBC. I was referring to the latter, you appear to have the former.

In your case there is another complication. While you can add the timezone info onto the DB name and can connect, once saved & closed the DB name is wrong. This is reported in tdf#119786.

Two methods to fix while bug is being fixed. One is to change to an older java connector (tested with 5.1.45) which works without added timezone info. Second method is to use JDBC Connection Type ( from menu - Edit->Database->Connection Type...) then set up using JDBC (not 'MySQL (JDBC)') type. The datasource becomes:

mysql://localhost/YOUR_DB_NAME?serverTimezone=America/Chicago
Ratslinger gravatar imageRatslinger ( 2019-03-20 17:33:58 +0200 )edit

Thank you! I downgraded to 5.1.47 and the connection has returned. Take the rest of the day off, with pay.

Bob Dale gravatar imageBob Dale ( 2019-03-20 20:30:39 +0200 )edit
0

answered 2019-03-20 04:17:42 +0200

Bob Dale gravatar image

Thank you for the fast reply. My only problem is I don't know where to edit the JDBC Datasource string. My search hasn't led to an answer.

Have a great evening.

edit flag offensive delete link more

Comments

@Bob Dale Please use add a comment for responding. Answers are to respond to original question only.

Ratslinger gravatar imageRatslinger ( 2019-03-20 04:41:17 +0200 )edit

Thanks, phat phingers hit the wrong button. My bad.

From the Base>Edit>Database>Properties the options are Advanced Properties (General, Name of MySQL database and User Authentication) and Additional Settings (Host name, Port number & MySQL JDBC driver class) and Data Conversion (Character set). I don't see a Datasource URL.

Sorry, but I must be missing something obvious.

Bob Dale gravatar imageBob Dale ( 2019-03-20 15:43:55 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-03-19 02:23:40 +0200

Seen: 58 times

Last updated: Mar 20