Ask Your Question
1

Scrolling and display problem (bug?) in LibreOffice 3.6 and above [closed]

asked 2013-06-10 14:35:42 +0100

cipricus gravatar image

updated 2015-10-04 19:30:12 +0100

Alex Kemp gravatar image

This question was initially posted here on askubuntu and also as a bug report here. I am sorry for this cross-posting but I was not able to get an answer to this. If I get one, I will solve the cross-posting issue, maybe delete the askubuntu question, which is already old... and was even closed initially as it had a different, long and unclear form.


So, I will try just to migrate that question here.

This problem started with a new version of LibreOffice, 3.6.2.2. (the one with the new green splash screen instead of the old white one) and continued up to the latest 4.x versions.

My documents are not displayed properly when I scroll up or down.

The problem appears only above a certain zoom level and is the same in odt or doc.

Example. Have pasted a text here

enter image description here

After scrolling down:

enter image description here

and down:

enter image description here

and then up:

enter image description here

Clicking on the text restores it but it always goes back to the beginning which is the only part that is visible in this way - and larger documents are almost unusable!

The document can be taken under control if the zoom is equal or lower than 180%. It may vary depending on display and resolution, but it seems to me that the problem disappears as soon as the zoom goes down so that the page is largely within the margins of the maximized window.

enter image description here

On my display the comfortable zoom level (the one that I would prefer to use, and cannot) would be 230% (e. g. with 11 Arial).


  • This also affects other parts of the office suite (Calc, Impress).

  • I never had display problems with this laptop before, and previous versions of Libreoffice worked ok.

  • I have tested with a live usb and the same LibreOffice version and the problem appears in the same manner.

  • This happened initially in Lubuntu 12.10, and then in Xubuntu 12.10 too, and in all versions of LibreOffice above 3.5.

  • I am able to use msoffice 2007 under Wine with no problem. To avoid the present issue, I use LibreOffice 3.5.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-11-03 01:55:53.362326

Comments

the same issue posted here - beside 3.5 a solution seems to be OpenOffice

cipricus gravatar imagecipricus ( 2013-06-10 19:50:28 +0100 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2013-06-10 22:10:55 +0100

cipricus gravatar image

updated 2013-07-01 18:51:36 +0100

There is no fix to this, probably a bug.

As practical solution, one or all of the following choices are useful:

  • avoid using more than 180% zoom (this may vary) in the versions that are affected

  • use a version that is not affected by this problem: 3.5, or latest OpenOffice (3.4.1, June 2013 - or later other that is similar to L.O. 3.5)

    (on how to use older and/or multiple versions look here.)

edit flag offensive delete link more

Comments

Actually OpenOffice 3.4.1, not 2.4.1. Thanks for the tips.

CyanCG gravatar imageCyanCG ( 2013-06-11 05:12:53 +0100 )edit
1

@CyanCG - thank you. it's fixed

cipricus gravatar imagecipricus ( 2013-06-11 10:32:40 +0100 )edit

webmaster@documentfoundation.org asks me to accept the answer, but cannot accept my own under 50 points

cipricus gravatar imagecipricus ( 2013-06-21 10:12:34 +0100 )edit

Here you go, an upvote will at least give you a few points ;) 10 per upvote on a question or answer, one per upvote on a comment.

CyanCG gravatar imageCyanCG ( 2013-06-26 23:27:36 +0100 )edit

@CyanCG - thnx, I still have some way to go until 50

cipricus gravatar imagecipricus ( 2013-06-27 16:48:44 +0100 )edit

@cipricus – That should work now. :)

manj_k gravatar imagemanj_k ( 2013-06-27 21:16:15 +0100 )edit

i have this issue in libreoffice 5.4, lubuntu 16.04 x64, openjdk-8-jdk, lspci -k | grep -EA3 'VGA|3D|Display' yields: - 01:00.0 VGA compatible controller:
NVIDIA Corporation GF108 [GeForce GT 430] (rev a1) Subsystem: eVga.com. Corp. GF108 [GeForce GT 430] Kernel driver in use: nouveau Kernel
modules: nvidiafb, nouveau my text is simply unusable in normal view i guess i can keep writing in WEB view, the bug seems to disappear, for now any suggestions to get lo5.4 working?

iurisegtovich gravatar imageiurisegtovich ( 2017-08-18 21:05:33 +0100 )edit

I just removed my nvidia and libre office is working flawlessly, i guess this might be a driver issue (i never installed official nvidia driver) somewhere between graphical interface libraries, ubuntu default graphic card driver driver and my nvidia card (maybe even hardware defect on my product).

iurisegtovich gravatar imageiurisegtovich ( 2017-08-25 23:22:33 +0100 )edit

Question Tools

2 followers

Stats

Asked: 2013-06-10 14:35:42 +0100

Seen: 1,968 times

Last updated: Jul 01 '13