Ask Your Question
0

XML Bug? <formula>L11< 0</formula> [closed]

asked 2013-06-10 15:16:48 +0200

MarcusB gravatar image

updated 2013-06-10 15:47:20 +0200

oweng gravatar image

Is it a know bug that calc's conditional formatting is stored in invalid XML using .xlsx? Sample: "L11< 0" should be "L11<0". This makes Excel ignore the complete sheet.

Thanks Marcus

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-16 18:05:43.571161

Comments

Which platform are you on and which version of LO are you using?

oweng gravatar imageoweng ( 2013-06-10 15:46:32 +0200 )edit

Can you please open a bug report for me? I'd need a test document to see if I can reproduce it. Even "L11<0" is wrong as < and > have to be escaped in a xml file.

moggi gravatar imagemoggi ( 2013-12-17 13:04:28 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2013-12-21 08:53:34 +0200

oweng gravatar image

I want to confirm that what I am seeing is a bug, because I am not convinced from the limited testing I have done. Under Ubuntu 10.04 x86_64 using:

  • v3.6.7.2 Build ID: e183d5b
  • v4.0.6.2 Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24
  • v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

I saved an ODS (created under v4.1.3.2) that contains a basic conditional formatting formula. In cells B1 through B3 the corresponding value of A1 through A3 (0, 0.5, 1) is checked to see if it is greater than 0.5 i.e., only cell B3 meets the conditional format. B3 has conditional format A3>0.5 and employs a cell background colour of red as a result (the modified Result cell style). Checking xl\worksheets\sheet1.xml generated in each XLSX from the above three versions shows this for cells B1, B2, and B3:

<formula>A1>0.5</formula>

<formula>A2>0.5</formula>

<formula>A3>0.5</formula>

Each of these XLSX are opened OK under Excel Mac 2011 and display the red background for cell B3. I then duplicated (using Classic conditional formatting) the same data and effects in Excel Mac 2011 and saved this to XLSX also. The XML reveals the same formatting (with absolute referencing):

<formula>$A$3>0.5</formula>

If there is a problem here, I am not seeing it. My test files are attached here (rename from JPG to ZIP) for others to check.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-06-10 15:16:48 +0200

Seen: 173 times

Last updated: Dec 21 '13