Ask Your Question
0

Stop AutoMacro from running

asked 2019-03-19 21:15:31 +0200

JohnnyG gravatar image

I have inherited a Base DB at work, whoever wrote it has attached a Macro to the “Open Document” event which seems to hide the DataBase main page and opens a “Switchboard” form, which works fine. The problem is there seems to be no way of getting back to the DataBase ie Tables, Forms etc, is there a way of preventing the Macro from running when I open the DB.

edit retag flag offensive close merge delete

Comments

Try setting macro security level to medium to control macro execution?

Mike Kaganski gravatar imageMike Kaganski ( 2019-03-19 21:41:39 +0200 )edit
1

Very High may be better. If file is set as trusted source Medium will do no good.

Additionally, if you know the macro causing the problem, start the Base file. Then open another LO document such as Calc (even new document). Should be able to access the Base macros from there. Then on the first line of the offending macro insert Exit Sub. Close all. Then the Base file will open without the hidden main page.

Ratslinger gravatar imageRatslinger ( 2019-03-20 00:15:47 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-03-20 09:54:07 +0200

JohnnyG gravatar image

Thanks for the quick reply. In messing! Around I had found a very similar fix, move the .ODB file to a different directory not covered by the \Macro security feature, when you start the DB the macro fails.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-03-19 21:15:31 +0200

Seen: 40 times

Last updated: Mar 20