Ask Your Question
0

How do I format all footnotes?

asked 2019-03-27 19:21:39 +0200

megro42 gravatar image

I've imported a document I wrote in Word into LibreOffice and it has 50+ footnotes. They were in Times New Roman font in Word and have become this default font in LibreOffice. The footnote number at the bottom of the page and the footnote text are in the default font. The anchor in the text is FreeSerif. I would like the footnotes to all be in FreeSerif like the rest of the document.

I've tried modifying the style of footnotes and footnote characters in the formatting manager. The footnotes remain in the old font.

I cannot highlight all because it seems LibreOffice lacks this feature so I cannot just select all and change the font.

What should I do so I don't have to change all of them one by one?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2019-03-27 20:00:43 +0200

ajlittoz gravatar image

Paragraph style Footnote controls the footnote paragraph appearance (margin, spacings, base font, etc.). You can tell if this the style in effect by putting the cursor in a note and looking for the style name in the paragraph style drop-down menu in the toolbar.

If style is not Footnote, modify the advertised one. In case this is really Footnote, there may be some "direct formatting" overriding the change. Select the note and Ctrl+M.

If that solves the problem, remove direct formatting from the whole document by Ctrl+A and Ctrl+M, but be aware that it could also remove "important" formatting from the import because M$ Word has no notion of character styles.

Character style Footnote characters controls only the note number in the footnote. It acts as an override over what Footnote provides.

edit flag offensive delete link more

Comments

Hi Ajlittoz,

I'm not sure what you mean by "the advertised one." I put the cursor in the footnote text, click the style drop down menu, and it is the same as when I put the cursor anywhere else: the defaults are checked.

The ctrl+M function does work to automatically change the formatting to my preset default instead of having to type in the font name for every entry. That will definitely save me time.

However, it still doesn't allow me to batch edit the footnotes. Although I will be writing documents in LibreOffice first going forward, I will still need a way to format the text of all footnotes. I copy-paste things from all over the internet that come out in different formats and then format everything at the end.

Thank you for your help so far!

Meg

megro42 gravatar imagemegro42 ( 2019-03-29 14:07:00 +0200 )edit

"Advertised one" meant the style that is displayed (or highlighted) in the menu.

Unfortunately, there is no way to select all footnotes and apply them commands/adjustments because they are not in the main text flow.or in a dedicated subflow.

Spurious formatting depend on how you enter your notes. I assume you first Insert>Footnotes & Endnotes>Footnote and then paste Ctrl+V your text. This also pastes the original formatting. Instaed, try Edit> Paste Unformatted TextorCtrl+Shift+Alt+V` (I know, not really user-friendly) so that will inherit paragraph style attributes without overrides.

The same holds for main text if you prefer to discard original formatting.

ajlittoz gravatar imageajlittoz ( 2019-03-29 14:29:48 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-03-27 19:21:39 +0200

Seen: 37 times

Last updated: Mar 27