Ask Your Question
0

Calc isn't sorting correctly

asked 2019-03-30 19:34:19 +0200

hackenberg gravatar image

In the last 2 updates to LibreOffice I have had trouble with my running totals column sorting properly. I looked it up in the Calc manual and it said to enable natural sort (sort options). I did this, and two things happened, it reverted the sheet first to its original unsorted condition, and it never keeps the "enable" box checked. After several tries on one spreadsheet page most of it fixed, but some of it I had to do over again. Even the function of grabbing one cell and dragging the corner to copy the formula to each of the following cells did not come out perfect. Sometimes the first cell number would be under the current cell or way down the sheet instead of the cell just above.
Going to a new spreadsheet, sorting on the dates with "enable" checked, I have attached a picture of the formula results. Each line is supposed to look like line 96 consecutively, but they are not. Column G is always supposed to be the number just above. The problem: 1) incorrect sort, 2) sort > options > enable natural sort doesn't stay checked.image description(http://)

edit retag flag offensive close merge delete

Comments

You didn't tell us which version you are using. Version 6.1.5 is the current stable release and is recommended for enterprise installations and users who don't like surprises. Version 6.2.2 is recommended for early adopters and power users (in other words, a few bugs might be expected).

ve3oat gravatar imageve3oat ( 2019-03-30 23:35:20 +0200 )edit

Version 6.2.2, but the version before this had the same problem. I was hoping 6.2.2 had fixed it.

hackenberg gravatar imagehackenberg ( 2019-04-01 23:18:29 +0200 )edit

I am not an expert at what is a bug and what isn't, but this sounds like a bug. It would be good for everyone if you reported it as such to Bugzilla https://bugs.documentfoundation.org/

ve3oat gravatar imageve3oat ( 2019-04-02 00:26:22 +0200 )edit

I have tried to go to bugzilla to report other bugs, but that site is for developers and programmers and I don't understand how to make a report to them. Maybe someone in "ask" can just forward this to them.

hackenberg gravatar imagehackenberg ( 2019-04-09 21:06:22 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2019-04-14 00:31:44 +0200

hackenberg gravatar image

I did try to report this to bugzilla. At the end of my report they asked if I had reset user profile. The solution was found here: https://wiki.documentfoundation.org/U... and it worked.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-03-30 19:34:19 +0200

Seen: 76 times

Last updated: Apr 14