Ask Your Question
0

How can I make Libreoffice Writer save the URL I pasted for an image link?

asked 2019-04-11 11:09:05 +0200

tonyz gravatar image

I pasted a URL in the Hyperlink Tab of an image in Writer. When I check it after closing the properties box, everything is okay. But upon saving, closing the document then re-opening, the link is gone and the image is no longer an image link. How can I get this sorted? I'm using Libreoffice 6.1.5.2 (x64), Win 10 Pro.

edit retag flag offensive close merge delete

Comments

The question confuses me. You start to write about an URL added for a hyperlink associated with an image and end with the term "image link", which is somehow not precise. Do you mean by "image link"

  • An image which directs you to a website (URL) when using CTRL - Click onto the image

-- or --

  • A link (URL) to an image, stored on your filesystem.

It might be a good idea, you upload a screenshot of the dialog, where you set the hyperlink.

Opaque gravatar imageOpaque ( 2019-04-11 12:05:37 +0200 )edit

I mean an image directing me to a website when I click CTRL-Click.

tonyz gravatar imagetonyz ( 2019-04-11 14:49:42 +0200 )edit

Ok - just installed 6.1.5.2 on my Windows 10 Pro and cannot confirm your observation. This worked for me. The only difference I can see is me having a "german locale" - installation.

Opaque gravatar imageOpaque ( 2019-04-11 15:16:44 +0200 )edit

You didn't mention which file format you use

Mike Kaganski gravatar imageMike Kaganski ( 2019-04-11 15:59:13 +0200 )edit

I'm saving the document as docx. Let me try with odt format and see what happens.

tonyz gravatar imagetonyz ( 2019-04-11 16:02:27 +0200 )edit

The .odt format saves the URL and the image is clickable, directing me to the website as expected. Maybe the problem is with the .docx format. I'll later on re-install Libreoffice and try again just to see whether there will be a difference. Thanks @Opaque for your assistance.

tonyz gravatar imagetonyz ( 2019-04-11 16:12:05 +0200 )edit

Sadly this site only allows comments containig at least 10 character ... and I'm biased enough to assume people using LibreOffice talk about native LibreOffice document formats.

Opaque gravatar imageOpaque ( 2019-04-11 16:18:10 +0200 )edit

Things work best when using the native formats. Crossing to the side of Microsoft formats can make you get stuck. At times it becomes necessary especially when working with MS Office users. All in all, LibreOffice is a great alternative, thanks to the developer community.

tonyz gravatar imagetonyz ( 2019-04-11 16:59:53 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-04-11 15:22:41 +0200

Opaque gravatar image

updated 2019-04-11 15:39:04 +0200

Hello tonyz,

if you want to check, whether the hyperlink is still there, you need to

  • Select the image and then
  • Menu Insert -> Hyperlink (or CTRL-K)

If the image is not selected, you will see an empty "hyperlink" dialog.

You may als check by selecting the image an right mouse click -> Properties ->Tab: Hyperlink

edit flag offensive delete link more

Comments

I have been checking that using the right mouse click->properties-> tab: hyperlink method. The image is supposed to direct me to a website upon left-clicking. Instead, because of the issue I mentioned, Ctrl+clicking doesn't do it. Checking the hyperlink tab on properties reveals an empty hyperlink box.

tonyz gravatar imagetonyz ( 2019-04-11 16:06:19 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-04-11 11:09:05 +0200

Seen: 30 times

Last updated: Apr 11