Ask Your Question
0

Calc insert mode not working

asked 2019-04-13 18:35:46 +0200

doctordruidphd gravatar image

This is libreoffice Version: 6.2.2.2 on kUbuntu 18.10.

Calc insert mode does not seem to be working. When I mark a row by clicking on the row number, then drag the drag box in the first column down to another row, hold down the ALT key then release the button, it overwrites, and does not insert. Seems it used to work this way.

edit retag flag offensive close merge delete

Comments

Works perfect this way on Windows 10 with LO 6.2.2.2 and also on UBUNTU 18.10.4. Possibly a problem with the ALT key? Can you try an other keyboard?

Cookievore gravatar imageCookievore ( 2019-04-13 20:45:45 +0200 )edit

ALT key seems to be working fine in other applications. Will have to find another keyboard to try.

doctordruidphd gravatar imagedoctordruidphd ( 2019-04-14 00:09:47 +0200 )edit

If ALT key works with other applications, we'll assume a working non defect keyboard. Other guess, ALT key used for other functionality within kUbuntu or assigned to a macro or what ever, that overlaps LO?

Cookievore gravatar imageCookievore ( 2019-04-14 12:31:39 +0200 )edit

Thanks. I booted the LTS version of kubuntu (18.04, I think) and LO worked just fine, ALT key works as expected. So I rebooted, removed my ~/.config/libreoffice directory, copied the one over from the LTS, and the ALT key still doesn't work. So it could be something inside LO but i doubt it, something in the OS or even something wrong with GTK or the NVIDIA driver. I guess just keep hacking away at it.

doctordruidphd gravatar imagedoctordruidphd ( 2019-04-14 17:17:10 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-04-14 18:25:26 +0200

doctordruidphd gravatar image

updated 2019-04-14 22:33:25 +0200

OK, I found the problem. The problem is with the libreoffice-kde5 integration package. Seems like this package has always been problematic, and in this case it is preventing the ALT key from working. Removing this package does restore ALT key functionality, but introduces another problem: LO comes up in a window that is some sort of GTK thing, and the menu bar, dropdown, etc fonts are too small to see comfortably. I have not been able to figure out how to change them. The KDE menus for changing GTK application font sizes do nothing, so LO is basically unusable in this configuration. Not sure how to proceed here, but the original problem does seem to be solved, even if not usefully.

Edit: Thanks to a user on another forum, I got the font problem solved. Apparently Libreoffice switches to a native interface, which is not really gtk, when the integration package is removed. Installing the libreoffice-gtk2 package fixed the whole mess.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-04-13 18:35:46 +0200

Seen: 56 times

Last updated: Apr 14