Ask Your Question
1

Background Color Not displaying

asked 2019-04-20 23:38:03 +0200

Prosybris gravatar image

In LibreOffice Writer, I am unable to show a paragraph background color if there is an active image as the page background. I've found the setting under the Format --> Paragraph menu to select a color for the "Area" of the paragraph. If I disable the background image, the paragraph color displays normally as expected, but as soon as I enable the page background image, the paragraph background color is not displayed anymore (even though it still show that I selected a paragraph background color in the properties menu.

Are you not allowed to have a paragraph background if there is a page background? If you should be able to do so, what am I missing?

I'm using LibreOffice version 6.2.2.2.

edit retag flag offensive close merge delete

Comments

I literally just registered here to ask the same question just in relation to table cell background colors, where I'm getting the same issue.

AndonRT gravatar imageAndonRT ( 2019-04-21 02:34:40 +0200 )edit

@AndonRT Why do you think Writer and Calc are the same? For a question, open your own question. Make it detailed. How do you proceed? When did something happen? If you are not sure, read the manual.

ebot gravatar imageebot ( 2019-04-21 08:55:40 +0200 )edit
1

@Prosybris - Please upload a sample file. I cannot confirm your statement. But there are some inconsistencies in defining page|area between OpenOffice and LibreOffice (OpenOffice can link images, LibreOffice cannot; linked images are not displayed in LibreOffice and other differences)...

Grantler gravatar imageGrantler ( 2019-04-21 13:28:14 +0200 )edit

Nevermind, I figured out a better way to do this. Instead of anchoring the background image to the header/footer, I added the background image to the page itself, removed the margins, and added a border padding equal to what the margins were. I think by adding the background image to the header/footer, it overlayed any background color of the paragraph.

It sure would be nice if I could set the page background to fill the entire page size without having to fiddle with the margins and border padding to get a proper background image, but it works.

Prosybris gravatar imageProsybris ( 2019-04-21 14:54:57 +0200 )edit

@ebot Why do you think I'm talking about calc? I'm not. There are tables in Writer. And that's what I am having the problem with. Don't assume people are dumb.

AndonRT gravatar imageAndonRT ( 2019-04-21 15:05:47 +0200 )edit

I've gone and made an example document, which can be found here. It shows that images and shapes set in the background will display underneath the text and borders of a table, and underneath the text of a paragraph, but will display over top of the background color, background image, and/or text background color. Text highlighting works (Format -> Character -> Highlighting). This is with Version 6.2.3.2

AndonRT gravatar imageAndonRT ( 2019-04-21 17:07:46 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2019-04-22 09:21:00 +0200

Grantler gravatar image

@AndonRT - Thank you for providing the sample file. This is an old problem (bug?) of AOO and LO. You can avoid the problems by these workarounds:

  • Put the table into a frame, the frame's area/background does not affect the display of the the cells' background colours.
  • Apply the background|page via menu format|page|Area|Colour or Bitmap (stretched) - the background does not dominate the table cells' color or background. For filling the entire page you have to set the page margins to 0 and additionally to set the border paddings to e.g. 2 cm each. Even if you have not chosen the page borders' colours (desired transparencies!) the paddings have a result. In this case you don't need to alter any paragraph styles (indents etc.).

Godspeed

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2019-04-20 23:38:03 +0200

Seen: 41 times

Last updated: Apr 22