Ask Your Question
0

Wide scrollbar obscures font sizes

asked 2019-04-25 17:33:05 +0200

peterfreeth gravatar image

updated 2019-04-25 18:49:28 +0200

ebot gravatar image

In all LO programs, the scroll bars for the main document window are fine, but the scroll bars for the style dialogue are so wide that sometimes I can't select anything in the column because the scroll bar obscures it.

I'm sure this is a gnome/gtk3 problem, but I can't find a way to change it. I have tried the gtk3 css file scrollbar width, that makes no difference.

Version: 6.2.2.2 Build ID: 1:6.2.2-0ubuntu2 CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3;

image description

edit retag flag offensive close merge delete

Comments

Am I right, that you just updated to Ubuntu 19.04?

Opaque gravatar imageOpaque ( 2019-04-25 22:18:05 +0200 )edit

You are right, but this has been a problem long before. I had a problem with not being able to scroll to the bottom of a list because the dialog box was too long, which is still a problem raised in a separate report. To fix that, I had LO load a different visual theme, that fix no longer seems to work. I have had some success with this scrollbar problem by modifying the gtk theme css file, though it doesn't seem possible to make the scroll bar any smaller, I can change the margins around it which at least allows me to select something behind it. I'm still trying to figure out all the css code though.

peterfreeth gravatar imagepeterfreeth ( 2019-04-26 10:14:59 +0200 )edit

Checked also on native packages for 6.2.3.2 from libreoffice.org on ubuntu 19.04 and confirm the behavior for the GNOME desktop (KDE desktop doesn't show this). From my point of view it is time to file a bug at https://bugs.documentfoundation.org/

Opaque gravatar imageOpaque ( 2019-04-26 16:04:31 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-04-28 10:43:29 +0200

peterfreeth gravatar image

Partly solved.

I found another gtk.css lurking in ~/.config/gtk3.0/

The slider can be adjusted, but the background scrollbar that the slider sits in apparently can't. However, by moving all the scrollbar css from the theme into the home folder, it does appear smaller, so that I can now actually select font sizes. This solution also appears to be independent of the theme you use.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-04-25 17:33:05 +0200

Seen: 38 times

Last updated: Apr 28