Ask Your Question
1

Paste loses cell format in Calc and other pasting issues [closed]

asked 2012-04-13 07:31:17 +0100

Zorba gravatar image

updated 2012-05-01 06:29:21 +0100

Hello,

The default function of paste seems to have changed and I find this change to be for the worse. I have noted the following changes:

  • Paste uses the formatting of the cell being pasted to, not the formatting of the cell being copied. There is no option to choose the copied cells formatting, which was previously possible. Before if you wanted to copy without formatting, you would use paste special.
  • Attempting to use Paste Special brings up the Paste Special dialogue but it shows the Source as 'Unknown Source' and the only Selection is 'Unformatted text'
  • Pasting more than one cell brings up the Text Import dialogue. Again there is no option to copy formatting and frankly it seems unnecessary compared to the previous function of simply performing the paste. [Update] I have also noted that this changes the characters to the text format (which is a terrible default setting imo) unless you select "Detect Special Characters". Then it will copy with the characters in the correct format but the cells format is not copied and no formulas are copied.
  • Paste will not copy to a cell where there is already content. There is not even an option to copy over the existing content. [Update] This I can not seem to replicate all the time but even if it does copy into a cell with content, the other issues still apply.
  • Merged cells get a special note because now you can not even copy an empty merged cell range. Now each cell range to be merged must be done individually or a macro recorded. This is very annoying if, for example, you wish to format a table within which two columns are merged throughout. Copying the merged cell range was previously a simply task, now it is onerous to the point of impracticality.

The default funtion of copy and paste has been consistent since I started using OpenOffice back at version 1. Why it has changed with the implementation of LibreOffice is beyond me. Pasting is a primary function of a spreadsheet and this change does not seem to improve functionality. With that said, I suppose the question is simple: Why has the default function of copy and paste been altered and when will it be restored to the standard function?

If there is reason for this change and I am simply not up to scratch with how to ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-01 14:06:57.320461

Comments

1

What is the source and destination of the copy / paste operation(s) of which you speak? It would appear you are talking about copying from a HTML source (e.g., web page) and pasting into Calc. Quite different from copy/paste between documents e.g., Calc / Writer.

oweng gravatar imageoweng ( 2012-04-13 13:40:17 +0100 )edit

Sorry about late reply. The issue occurs with copy paste of cells in the same spreadsheet. No external sources or destinations. Considering the loss of function I have observed, I am surprised this does not appear to be a more common problem.

Zorba gravatar imageZorba ( 2012-05-01 06:01:56 +0100 )edit

Sorry, but I run LO 3.4.6 on mac OSX 10.7 and LO 3.5.2 on Ubuntu Linux 10.4 and everything works fine. I cannot reproduce any of the behaviours you are describing.

mikebibo gravatar imagemikebibo ( 2012-05-01 12:40:51 +0100 )edit

Thanks, that's good to know. I run on Win7 64. I tried repairing the install and it began to work but not consistently, Have just reinstalled and it appears to be working correctly now. Will confirm after a few days testing before updating officially. Hopefully it was simply a weird install error!

Zorba gravatar imageZorba ( 2012-05-01 14:29:37 +0100 )edit

12 Answers

Sort by » oldest newest most voted
0

answered 2013-02-25 07:04:43 +0100

qubit gravatar image

Looks like the problem may be fixed...

@Zorba writes (May 1 '12):

I run on Win7 64. I tried repairing the install and it began to work but not consistently, Have just reinstalled and it appears to be working correctly now. Will confirm after a few days testing before updating officially. Hopefully it was simply a weird install error!

If you're still experiencing issues:

If installing the latest release doesn't seem to fix this problem, please file a bug and provide a list of steps that can reproduce it. The QA team will be happy to help you track down this issue!

Please post a link to any bugs you file in a comment below using the format "fdo#123456".

Thanks!

edit flag offensive delete link more
0

answered 2013-09-16 21:26:54 +0100

Pasting more than one cell brings up the Text Import dialogue

This is definitely not fixed as of LibreOffice 4.1.0.4 410m0(Build:4) on Debian Wheezy.

It is easy to reproduce. select a line by clicking the line number. Copy it Try to paste it by clicking another line number. It does not work. (once upon a time ...) Copy the line again. Paste into the first cell of a line. THAT works. Now select a column of first cells and Paste into them. You get the Text Import dialog!

edit flag offensive delete link more

Comments

Bug 69774 - EDITING: Pasting more than one cell brings up the Text Import dialogue

fdo#69774

Mike Bianchi gravatar imageMike Bianchi ( 2013-09-24 23:20:42 +0100 )edit
0

answered 2012-12-28 01:13:04 +0100

As a reference I was googling "libreoffice copy to column with different format" and I found this post.

Context: OpenSuse in German Programs: LibreOffice 3.5:build-403 Kwrite Version 4.8.5 (4.8.5) "release 2"

What: Trying to copy from kwrite a column of dates into a date type pre-formatted column of librecalc.

Problem: Using default options caused Librecalc to insert cells in string format, instead of the date format I had set up previously to pasting.

Solution: In the dialog of paste, go to Fields (or "Felden" in German) and select the "US-Englisch" option instead of "Standard". Then the cells are input and formatted accordingly.

Ej. input "raw" date: 2012-12-16 Librecalc's pre-Formatted cells now recognize this input as: "12/16/12"

Previously it only pasted "2012-12-16" and I was unable to change that format until I performed the afore mentioned procedure.

HTH

edit flag offensive delete link more
0

answered 2012-12-28 01:12:36 +0100

As a reference I was googling "libreoffice copy to column with different format" and I found this post.

Context: OpenSuse in German Programs: LibreOffice 3.5:build-403 Kwrite Version 4.8.5 (4.8.5) "release 2"

What: Trying to copy from kwrite a column of dates into a date type pre-formatted column of librecalc.

Problem: Using default options caused Librecalc to insert cells in string format, instead of the date format I had set up previously to pasting.

Solution: In the dialog of paste, go to Fields (or "Felden" in German) and select the "US-Englisch" option instead of "Standard". Then the cells are input and formatted accordingly.

Ej. input "raw" date: 2012-12-16 Librecalc's pre-Formatted cells now recognize this input as: "12/16/12"

Previously it only pasted "2012-12-16" and I was unable to change that format until I performed the afore mentioned procedure.

HTH

edit flag offensive delete link more
0

answered 2012-11-16 13:13:40 +0100

Yes, I agree with original post. It is broken and exhibits random behaviour. Most (if not all) of the problem with Paste and Paste Special happen when you try to Paste into multiple cells. Sometimes you get the Text Import dialogue, sometimes you get the Paste Special dialogue with source "unknown source".

The very basic spreadsheet operation of copying the contents of a single cell and pasting it into multiple cells seems to be impossible! Try this:

Copy a single cell; select a range of cells and try to Paste;

Up pops a dialogue called Text Import (why?!), you press OK and nothing happens.

It is braindead and practically unusable as a spreadsheet.

edit flag offensive delete link more
0

answered 2013-01-19 05:29:23 +0100

Confirmed to be a problem on Win7 64bit v 3.6.4.3.

All cut-and-paste looses formatting, including from within the same Writer document. Ctrl+Shift+V only shows unformatted text as option.

Anyone know where the bug tracker is? Anyone have troubleshooting instructions or fixes

edit flag offensive delete link more

Comments

@PleaseGIveMeBackMyKDE -- Here's the link to file a bug.

Please post a link to any bugs you file in a comment below using the format "fdo#123456".

qubit gravatar imagequbit ( 2013-02-25 07:03:05 +0100 )edit
0

answered 2015-09-25 13:24:13 +0100

shee-eet gravatar image

updated 2015-09-25 13:24:45 +0100

I've got cells formatted as 'Text'.

When I paste into them from an HTML table of text, LibreOffice changes the cell formatting to 'Number'.

I have to manually go in to cell formatting to change them back to text.

Version: 4.2.8.2 Build ID: 420m0(Build:2)

edit flag offensive delete link more
0

answered 2012-05-03 21:27:08 +0100

mahfiaz gravatar image

BlipBertMon, you should try Ctrl+Shift+V, Paste Special and uncheck "Formatting".

edit flag offensive delete link more
0

answered 2012-07-13 08:02:39 +0100

CADutchman gravatar image

Experience the same problem: sheet copy small vertical range of cell with formula to paste on the same sheet in the same column and its reports "Unknown Source" and offers "Unformatted Text." However, the pasting occasionally does work as expected. But there's clearly a random bug at work.

edit flag offensive delete link more
0

answered 2012-05-01 23:40:52 +0100

m.a.riosv gravatar image

Maybe your profile is corrupted. See more about profile: http://wiki.documentfoundation.org/UserProfile

edit flag offensive delete link more

Question Tools

2 followers

Stats

Asked: 2012-04-13 07:31:17 +0100

Seen: 14,652 times

Last updated: Sep 25 '15