Ask Your Question

no dead keys in libreoffice, but OK in other apps [closed]

asked 2013-06-19 23:52:10 +0200

mario.storti gravatar image

updated 2016-03-03 16:32:32 +0200

Alex Kemp gravatar image

I have LibO (under Fedora Linux 18, KDE 4.10.3). I have an US-international keyboard. In all applications (Emacs, Kate, Firefox, Inkscape, you name it) I can compose diacritics using dead keys combination, for instace '+a -> á and so on. This used to be this way also for LO until my last upgrade to Fedora 18. Now this doesn't work anymore (just for LO) and I have to compose diacritics with the AltRight key, for instance AltRIght+a -> á. First it annoys me because I'm so used to use the dead keys, and now I have to incorporate this new combination. I don't quite understand why this is different just for LO. In addition I don't know how to compose other diacritics like grave accents, carets (à, â). Can I configure LO so as to use the dead keys? TIA, Mario

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-03 16:32:50.902652


Have you tried resetting the user profile?, sometimes solve strange issues.

m.a.riosv gravatar imagem.a.riosv ( 2013-06-20 01:03:03 +0200 )edit

I have the same problem, but I didn't find this post at first because I used the incorrect search keys. Any solutions yet?

jlinkels gravatar imagejlinkels ( 2013-08-01 15:54:40 +0200 )edit

I have marked the original question up to give the OP some karma (so they can comment back here if they found a solution). I am unsure why this would be an LO-specific issue. I would think that LO simply uses system settings. @jlinkels did you use the deb download package from the LO website? So long as you install all contained packages you should be able to discount a missing package as a cause. Have you installed the US Intl k/b? Set /etc/default/keyboard as above?

oweng gravatar imageoweng ( 2013-08-02 13:07:20 +0200 )edit

The OP isn't the only person experiencing this problem. There are a couple bug reports concerning nonfunctional dead keys in LibreOffice. The problem may be related to IBUS. See for further details.

psychonaut gravatar imagepsychonaut ( 2014-02-07 18:05:53 +0200 )edit

On my Ubuntu 12.04 system the keyboard configuration app shows the keyboard layouts. Or try Google us international keyboard layout to display and print the US-International keyboard layout. In Europe we would use the Alt Gr key at the normal way to use the French, German accents. On many American keyboards the Alt Gr is just labelled as the right hand Alt key.

petermau gravatar imagepetermau ( 2014-02-08 10:23:02 +0200 )edit

I have exactly the same problem. LO on Kubuntu Trusty Tahr. My keyboard is well configured. I get the accents in almost all other applications.

Lenov gravatar imageLenov ( 2014-09-03 15:57:17 +0200 )edit

1 Answer

Sort by » oldest newest most voted

answered 2013-06-20 01:21:15 +0200

oweng gravatar image

updated 2014-09-05 17:18:43 +0200

As the comment above by @psychonaut indicates, bug fdo#71437 reports a possible IBUS conflict under GNU/Linux with a workaround of:

$ unset XMODIFIERS && libreoffice4.2 &

Note that libreoffice4.2 in the above command will need to be in the $PATH (or modified to point to soffice in the LO install location. Also, perhaps examine what /etc/default/keyboard contains e.g.,:


The layout and variant values can be set by issuing:

$ setxkbmap -layout us -variant intl
edit flag offensive delete link more


In case that didn't work: it may be a problem with the libreoffice UI backend; see the second part of my answer here.

cipricus gravatar imagecipricus ( 2018-07-26 10:48:52 +0200 )edit

Question Tools


Asked: 2013-06-19 23:52:10 +0200

Seen: 1,650 times

Last updated: Sep 05 '14