Ask Your Question
0

Windows Libreoffice 6.2.3 - PostgreSQL SDBC driver error

asked 2019-05-11 16:41:45 +0200

luigibr gravatar image

Is there any binary for windows with postgres-sdbc driver for download on www.libreoffice.org?

I downloaded the windows installer and tried to connect to a PostgreSQL db and get this error: "The connection to the external data source could not be established. No SDBC driver was found for the URL"

edit retag flag offensive close merge delete

Comments

Hello,

Could you please clarify on how you tried to connect? Have been using PostgreSQL SDBC on Linux for some time without problem including 6.2.3.2

Ratslinger gravatar imageRatslinger ( 2019-05-11 17:27:08 +0200 )edit

Hi! I am using this on Linux too without problem. When i tried to use this connection on Windows, i got this problem. I downloaded the binary for windows on www.libreoffice.org and get this problem. On Linux, i install postgres-sdbc and everything works fine. On windows, i cant find something similar. I was thinking if is possible download the binary of postgres-sdbc driver for windows. If not, maybe the only solution is compile a binary for windows with that option?

luigibr gravatar imageluigibr ( 2019-05-11 21:13:08 +0200 )edit

Did not need to install anything on Linux for SBDC connection. Was in drop down list each time a version was installed.

Cursory view doesn't show any bugs outstanding for this. Don't have current Windows to test (just very old slow version). You may need to file a bug report -> Bugzilla

Ratslinger gravatar imageRatslinger ( 2019-05-11 21:20:34 +0200 )edit

To get this error, i did: (on Windows) 1. Open Libreoffice Base > Database Wizard 2. Select "Connect to a existing database" and select "PostgreSQL". Next 3. Datasource URL. host=localhost:5432 dbname=mydb . Next 4. Username and Test connection

at this point i fill the password and get this error: "A driver is not registered for the URL host=localhost:5432 dbname=mydb"

I tried without testing the connection and get this error. "SQL Status: HY000

The connection to the external data source could not be established. No SDBC driver was found for the URL host=localhost:5432 dbname=mydb"

luigibr gravatar imageluigibr ( 2019-05-11 21:29:03 +0200 )edit

Thanks Ratslinger!

luigibr gravatar imageluigibr ( 2019-05-11 21:30:03 +0200 )edit

@luigibr Using your setting I get similar error. Will test further & post result.

Ratslinger gravatar imageRatslinger ( 2019-05-11 21:49:46 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-05-11 22:13:00 +0200

Ratslinger gravatar image

Hello,

Have done some further testing using Mint 18.3 with LO 6.2.3.2.

When creating a NEW Base file with SBDC connection always get error of differing types when trying to test connection. Can save though and then enter connection information ( I used postgresql://localhost:5432/mydb) and this gets a successful connection. May work on Windows also.

Definitely a bug & should be reported.

edit flag offensive delete link more

Comments

Note: You can enter info after save from menu - Edit->Database->Properties... & Edit->Database->Connection Type...

Ratslinger gravatar imageRatslinger ( 2019-05-11 22:29:47 +0200 )edit

Thanks Ratslinger, i tried that and this workaround works on Windows too. Many thanks for your help!

luigibr gravatar imageluigibr ( 2019-05-12 04:49:53 +0200 )edit

I found the same bug under Debian using LibreOffice 6.2 (AppImage): Bug 125168

Sébastien gravatar imageSébastien ( 2019-05-12 13:50:59 +0200 )edit

As noted in tdf125221host=localhost dbname=mydb does work contrary to what is noted in Wizard.

However, please note. If a mistake is made on entering information, you will likely get errors until you start from the beginning - meaning close all LO processes including the Base create. Otherwise the error will continue. You can still save as noted in the answer.

Still buggy in my estimation. Along with mentioned errors for mistaken entries, you should be able to specify a port.

Ratslinger gravatar imageRatslinger ( 2019-05-12 23:52:32 +0200 )edit

It appears every DB connection for Base has its' own idiosyncrasy! Can set new connection with port using postgresql://localhost:5432/mydb. This has the same problem mentioned in last comment about errors. Enter it correctly the first time and it works. Make any error and you need to start completely over including closing ALL LO open aps.

Ratslinger gravatar imageRatslinger ( 2019-05-13 01:45:12 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2019-05-11 16:41:45 +0200

Seen: 78 times

Last updated: May 11