Ask Your Question
0

How to use Copy > Paste Special > Link in Calc

asked 2019-05-15 10:43:15 +0100

lonk gravatar image

updated 2019-05-15 10:51:18 +0100

  • Right Click on a cell in Sheet1
    • Select Copy
    • Select Sheet2
    • Right Click on a cell in Sheet2 (or select Edit menu)
    • Select Paste Special > Options: Link / Operations: None / Shift Cells: Don't Shift > OK
    • Nothing happens.
    • Can you please help?
    • [ Fedora 30 - KDE Plasma - LibreOffice 6.2.3.2 installed from package ]
edit retag flag offensive close merge delete

Comments

Works for me like a charm on Fedora 30 - KDE Plasma - LibreOffice 6.2.3.2 - sometimes these kind of problems are related to clipboard manager. Clear clipboard and and try again.

Opaque gravatar imageOpaque ( 2019-05-15 12:18:58 +0100 )edit

@Opaque I have cleared 'Clipboard Contents' on the panel. The result is still the same, blank cell.

lonk gravatar imagelonk ( 2019-05-15 13:26:04 +0100 )edit

Ok - I got no other idea, since I tested with everything the same tool and version and the only difference I can see, is your user profile. You may try to call LibreOffice from command line using libreoffice --save-mode and Continue in Safe Mode (at bottom of the popup). If the problem is gone, then there is some corruption in your profile, if not, then ...

Opaque gravatar imageOpaque ( 2019-05-15 14:14:16 +0100 )edit
1

How are these items selected?

image description

Schiavinatto gravatar imageSchiavinatto ( 2019-05-15 14:48:32 +0100 )edit

You are right - at least "Text" needs to be ticked in addition to "Link"

Opaque gravatar imageOpaque ( 2019-05-15 15:13:00 +0100 )edit

@Gilberto Schiavinatto > Thank you so much. Selection: Text, Numbers and Date&Time must be ticked for Options: Link.

lonk gravatar imagelonk ( 2019-05-16 05:17:47 +0100 )edit

@lonk. Select as needed.

Schiavinatto gravatar imageSchiavinatto ( 2019-05-16 13:00:38 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-05-17 06:16:13 +0100

lonk gravatar image

The answer is in 'Comments' of Post no. 1

edit flag offensive delete link more

Comments

The answer is not working for me. I have only been using LibreOffice a short time, and the paste special>paste special>link was working fine but now I either get just the formula, an error:504 or nothing changes (blank cell). I have tried various variations in the paste special options, including the recommendations above and have cleared the Windows 10 clipboard. LibreOffice 6.4.0.3 (x64) Build ID: b0a288ab3d2d4774cb44b62f04d5d28733ac6df8 CPU threads: 8; OS: Windows 10.0 Build 18363; UI render: default; VCL: win; Locale: en-US (en_US); UI-Language: en-US Calc: threaded

I am adding the following: The problem only happens when I try a paste special > link from one document to another one. No problem in doing a paste special > link within a worksheet.

caughtintheact gravatar imagecaughtintheact ( 2020-02-04 06:47:11 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-05-15 10:43:15 +0100

Seen: 207 times

Last updated: May 17 '19