LibreOffice Impress PageObject Links from Microsoft Powerpoint Not Functioning

asked 2019-05-17 09:38:19 +0200

I have a presentation that was created in Microsoft Powerpoint. During the slideshow, there are many PageObject links that server as hyperlinks to other slides. In Powerpoint, when these are clicked, the user is taken to the resulting slide. This allows the presentation to move backwards and forwards with dynamic navigation.

In LibreOffice Impress, these links don't work. In either Edit mode or Slide Show mode, the link has to be selected, then the 'Next Slide' button has to be selected afterwards, otherwise nothing will happen. This is tedious and inconvenient. Given that PageObject links are one of the most basic fundamental functions in presentation formats, I would have expected to this work simply by opening the Powerpoint file in LibreOffice Impress.

How can I resolve issues with slide links from a Powerpoint document within LibreOffice Impress? Would it need to be imported/converted?

edit retag flag offensive close merge delete

Comments

Please provide a sample presentation to see the problem.

Mike Kaganski gravatar imageMike Kaganski ( 2019-05-17 09:44:34 +0200 )edit

I'm attempting to upload a presentation file that is 4.4MB in size. However, I receive the message prompt: "maximum upload file size is 1048576K".

craston gravatar imagecraston ( 2019-05-21 05:18:53 +0200 )edit

Upload to any online share, like dropbox, and post a link here

Mike Kaganski gravatar imageMike Kaganski ( 2019-05-21 07:09:26 +0200 )edit

https://file.io/5GqlCX

I have included a sample presentation in the link above. The yellow buttons in the presentation are links to other slides. They function correctly in Microsoft Powerpoint. They do not function in LibreOffice Impress.

craston gravatar imagecraston ( 2019-05-21 07:29:27 +0200 )edit

It works here with Version: 6.2.4.2 (x64) Build ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64 CPU threads: 12; OS: Windows 10.0; UI render: GL; VCL: win; Locale: en-US (ru_RU); UI-Language: en-US Calc: CL

But - I can confirm that KR - Menu and PRESCRIPTIVE buttons don't work on questions 3 and above (unlike in PowerPoint, where they work on all slides) - which is something you are welcome to file a bug report.

Mike Kaganski gravatar imageMike Kaganski ( 2019-05-21 07:59:20 +0200 )edit