Writer: bug in frame wrap?

asked 2019-05-17 11:15:36 +0200

ajlittoz gravatar image

updated 2019-05-17 14:11:59 +0200

This is a confirmation request before I file a bug.

I prepared a test document to answer a question in another language leg of this site and it seemed to uncover a bug or at least a non-document behaviour.

Context

A frame anchored to paragraph, horizontally positioned left on paragraph text area so that it aligns with paragraph indent.

The test document shows various combinations of frame position parameters and paragraph indents as shown in:

image description

Bug?

In case C, paragraph is styled Text Body Indent with indent increased at 5 cm to visually emphasize all effects. Image has a guard spacing of 0.5cm on its right.

I'd expect the spacing between image and text to be 0,5cm. Instead, spacing is the sum of this guard space and paragraph Before indent. This seems to me an error since indent has already been taken into account to position paragraph text area. There is no point using it a second time to "clear" the image.

Is it a bug or an intended feature not well documented?

Configuration

LO 6.0.7.3 - Fedora 29

Bug filed as tdf#125336

edit retag flag offensive close merge delete

Comments

I'd say - just file it.

Mike Kaganski gravatar imageMike Kaganski ( 2019-05-17 11:20:01 +0200 )edit

tdf#125336 - Paragraph indent used twice when positioning frame - confirmed with Windows 10 Home; Version 1809; 64-Bit | LibreOffice, Version: 6.2.3.2 (x64) in Bugzilla.

ebot gravatar imageebot ( 2019-05-17 13:28:04 +0200 )edit

@ebot: danke schön, ich erinnerte nicht Bug Syntax.

ajlittoz gravatar imageajlittoz ( 2019-05-17 14:10:35 +0200 )edit

Ja gerne. I also had to look first.

ebot gravatar imageebot ( 2019-05-17 14:13:12 +0200 )edit