Ask Your Question
0

Autoupdate formatting problem, especially with body text.

asked 2019-05-25 07:45:45 +0200

JackyAnn gravatar image

This is a LibreOffice writer problem. When I change body text in styles to how I want it, then to make it apply I have to highlight click every place in a document where I want body text. I cannot make it update throughout the document. I want the spacing proportional to 125%. I have auto-update checked. The same problem is happening on other styles despite auto update being checked, but intermittently. Please, can anyone suggest a fix? I have a 200 page document and my current method will take forever!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2019-05-25 08:17:16 +0200

ajlittoz gravatar image

This should not happen. Are you sure your paragraphs are styled Body Text? Strangely enough (but it is technically logical), Writer start in Default Style. It switches to Body Text after the next Heading n. Consequently, when beginning to write a new document, you must explicitly force an initial Body Text paragraph.

Autoupdate has nothing to do with "style change=>paragraph formatting sync" (this is nevertheless the standard and cannot be disabled), but works as "paragraph formatting change=>style updated". This is triggered by direct formatting.

From my experiments, autoupdate causes bad interferences between direct formatting (used to "autoupdate" style) and style definition in the dialog.

As is the rule, direct formatting should not be used outside experimenting and your case is no exception. The direct formatting used to change the style appearance remains in the paragraph where it was applied and takes precedence over the parameters coming from the style. If you apply various direct formatting in different paragraphs, you end up with a real mess.

To fix your problem, uncheck Autoupdate box in styles. Remove all direct formatting and work only with styles.

If you need bold or italics only on a word, apply a character style, don't use toolbar button, keyboard shortcut ou menu command (they all are direct formatting).

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Comments

@ajlittoz I am always happy how well you make your explanations. Especially your tests on this "first cream". (You say that in English too). I like to vote for your answer.

ebot gravatar imageebot ( 2019-05-25 09:11:14 +0200 )edit

@ebot: danke schön, sehr angenehm

ajlittoz gravatar imageajlittoz ( 2019-05-25 09:34:42 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-05-25 07:45:45 +0200

Seen: 22 times

Last updated: May 25