Ask Your Question
2

Foreign Scripts in Font Pull Down ... Why?

asked 2019-05-25 13:16:03 +0200

icedvolvo gravatar image

updated 2019-05-25 15:13:48 +0200

ebot gravatar image

Hi, the examples of fonts in the fonts pulldown have sandscrit like words next to them .. what is this and why are they there

See the screenshot attached

Any ideas for a fix appreciated ...

Screenshot.png

edit retag flag offensive close merge delete

Comments

A large part of the fonts are provided by your operating system. Some fonts are also supplied by LibreOffice. Fonts are usually installed or uninstalled via the operating system. Ask for the manual of your operating system.

ebot gravatar imageebot ( 2019-05-25 13:59:16 +0200 )edit

Good Question! If you highlight a name on the left, the name on the right is also highlighted, as if it were an alternative name. But not every name on the left is paired with a name on the right. And some of these right-hand names are in scripts that I suspect are Chinese, Arabic, Sanscrit, and many others that I don't recognize. It is inconsistent. Also I see the same left-hand font names when I open WordPerfect (as I would expect) but none of the right-hand scripts are listed in WordPerfect. This "problem" seems peculiar to LO (at least in v6.1.5).

ve3oat gravatar imageve3oat ( 2019-05-25 15:49:20 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2019-05-25 16:10:00 +0200

ajlittoz gravatar image

This is an intended feature in Writer.

Many fonts are targeted for a specific non-latin script. The list on the left is the basic list of font names with their names in Latin characters (usually English language). The name is displayed using the font itself as a sample of the result.

For a non-Latin target, another sample is added to the right with the name of the font in the target script.The screenshot displays names in several scripts from India,

If you don't like it (as you likely don't use these scripts), this can be disabled through Tools>Options, LibreOffice>Advanced, Open Expert Configuration. However, since I'm no developer, I can't tell which parameter to change (there are so many!).

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Comments

Ok thanks for that but I suppose i have to ask WHY? The language and script are set to Western and English ... There is no reason to show non Latin characters ....

icedvolvo gravatar imageicedvolvo ( 2019-05-26 10:35:40 +0200 )edit
1

Yes and no, when a font face is mainly intended for a non-Latin script, glyphs in the Latin block(s) are generally copied from a commonly available type face and have generally a poor rendering. As an example, take Lohit Devanagari where Latin is a basic "sans" font. It is interesting from a Westerner point of view to see "Western" version of the font in order to avoid it and from an Indian point of view to immediately recognise the font as being able to handle Devanagari language. I don't see it as an annoyance.

However, the real question is: why did the OS packagers force installing such font set while, like you, I only use the Latin script and did not load Asian scripts and language pack? My system (Fedora Linux) is "polluted" by these fonts.

If I try to uninstall them, the dependency analyser removes so many ...(more)

ajlittoz gravatar imageajlittoz ( 2019-05-26 12:08:44 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-05-25 13:16:03 +0200

Seen: 41 times

Last updated: May 25