Ask Your Question
0

libreoffice linux (Mint 19.1) local file links in Writer getting corrupted

asked 2019-05-26 15:28:23 +0200

jonboy99 gravatar image

updated 2019-05-26 15:32:26 +0200

Hi,

I'm not sure if this is due to me going about this the wrong way, but I am having this issue reproducibly.

Whenever I insert an html link or a link to a local file on my hard drive, into a Writer document, the link works fine until I close and exit the Writer file, then reopen it. After doing this, the link becomes corrupted as in the following example:

I create the following link in writer, either using the ctrl-K shortcut, or by just typing the text and pressing enter: file:///home/jon/textfile.txt

If I then ctrl click the link, the file opens as expected. If I hover over the link, the link text file:///home/jon/textfile.txt

appears as expected.

However, if I close the Writer file, then reopen it, ctrl-clicking the link will not work. If I hover over the link, or edit it using ctrl-K, the link text has changed to:

../../../../../textfile.txt

Same for html files saved on my hard disk.

Is this just a bug, or is there something else I'm doing wrong? All the links work perfectly until I close and reopen the writer file.

At the moment, this is quite an inconvenience - my work has provided my with some large html files which I have downloaded onto my disk for offline use. As I work through these files, I am making notes in Writer, then using html links to make specific references to locations in the html files. These links are all getting corrupted in this way. At the moment I am just working around the issue by copying and pasting the text for the link straight into my browser, but this obviously negates the benefits of hyperlinks!

Thanks for any help

Linux Mint 19.1, fully updated. Writer Version: 6.0.7.3 Build ID: 1:6.0.7-0ubuntu0.18.04.5 CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; Locale: en-GB (en_CA.UTF-8); Calc: group

Jon

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2019-05-27 04:27:00 +0200

jonboy99 gravatar image

I have discovered the problem. It appears to be a bug when saving writer files as docx. None of the above issues occur when saving in .odt format.

As Microsoft word is not likely to have to handle hyperlinks in a unix file system, I'm not sure how easy this will be to fix.

Jon

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-05-26 15:28:23 +0200

Seen: 33 times

Last updated: May 27