Ask Your Question
0

F4 not working

asked 2019-06-06 11:22:30 +0200

kweezel gravatar image

I just want to open the view database menu in my Write document, thats it. Pressing F4 does not work, there is no Database item when I look in View.

In the documentation it is clearly stated that it should work as long as you have a Writer document OR Base database open (opening the database does not cause the F4 button to work either).

This is ridiculous.

edit retag flag offensive close merge delete

Comments

Which OS and LO-Version do you use? And which Version of Documentation du you read?

Sometimes something can change.

ebot gravatar imageebot ( 2019-06-06 15:07:44 +0200 )edit

Are you aware that each key code may be intercepted by your operating system and its display manager? This also would bypass each documentation.

Opaque gravatar imageOpaque ( 2019-06-06 15:38:29 +0200 )edit

The default is actually Shift + Ctrl + F4 and this is ONLY to display Registered databases.

Ratslinger gravatar imageRatslinger ( 2019-06-06 17:57:57 +0200 )edit

We use Ubuntu 18.04 and the Libreoffice Version = 6.0.7.3 Build ID: 1:6.0.7-0ubuntu0.18.04.6. Sure things change, but you can't build a business on functionality like that no longer being available all of a sudden.

kweezel gravatar imagekweezel ( 2019-06-06 17:58:14 +0200 )edit

Shift + Ctrl + F4 does not work either.

kweezel gravatar imagekweezel ( 2019-06-06 17:58:48 +0200 )edit

Possible problem with user profile. See this post -> LibreOffice user profile

Ratslinger gravatar imageRatslinger ( 2019-06-06 18:02:01 +0200 )edit

So are you stating View->Data Sources does nothing or that your database does not appear in the list?

Ratslinger gravatar imageRatslinger ( 2019-06-06 18:04:39 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2019-06-06 23:15:58 +0200

Opaque gravatar image

updated 2019-06-06 23:23:08 +0200

Hello,

my Ubuntu 18.04 test installation showed the same behaviour as described and indeed there was no View -> Data Sources menu entry as asked by @Ratslinger. Performing a

sudo apt install libreoffice-base

fixed the issue. So please check first, whether you have the following output

user@system:~$ dpkg --list  libreoffice* | grep base
un  libreoffice-base        <none>                <none> (no description available)
ii  libreoffice-base-core 1:6.0.7-0ubuntu0.18.04.6 amd64  office productivity suite --shared library

If this is the case, then install libreoffice-base as per command above.

If the answer is correct or helped you to fix your problem, please click the check mark (✔) next to the answer.

edit flag offensive delete link more

Comments

@Opaque

Did not think of Base not being installed. This is typical of distro installs and I usually have TDF versions.

Ratslinger gravatar imageRatslinger ( 2019-06-06 23:22:58 +0200 )edit

@Ratslinger - me neither, when adding my first comment and I also use TDF releases for my production system.

Opaque gravatar imageOpaque ( 2019-06-06 23:23:59 +0200 )edit

Nice catch!

Ratslinger gravatar imageRatslinger ( 2019-06-06 23:27:51 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-06-06 11:22:30 +0200

Seen: 27 times

Last updated: Jun 06