Ask Your Question
0

why can't measurement be changed from inches to mm in Base

asked 2019-06-06 11:40:46 +0200

pawinda gravatar image

Several LibreOffice modules allow you to change the measurement system from inches to mm. Why can't this be done in LibreOffice Database.

edit retag flag offensive close merge delete

Comments

Please explain the meaning of "measurement system" with respect to a database? If you define a database table e.g. "MyObjects" having a column "length" and a column "width" you'll define 'em having a "double" type value. So it is up to you, what you mean by each value of the table (For sure you should instruct users of your database what you mean - so you could call your columns "length_in_mm" and "width_in_mm" to be more precise, but the values stay to be double.)

Opaque gravatar imageOpaque ( 2019-06-06 16:32:58 +0200 )edit

When I say measurement system, I mean that I need the rulers on the report design view to be in mm rather than inches so I have more precise placement of fields. Write, Calc, etc. allow changing units from inches to mm in the Tools>Options dialogues.

pawinda gravatar imagepawinda ( 2019-06-07 02:12:34 +0200 )edit
1

OK - then the only option I see would be to change Tools -> Options - Language Settiings -> Languages -> Category: Language Of -> Option: Locale setting to a variant of English (e.g. English (UK)), where the default is using a decimal system (this also doesn't allow to change the ruler showing mm but shows cm). All other requirement should go to an anhancement request.

Opaque gravatar imageOpaque ( 2019-06-07 08:40:38 +0200 )edit

Thank you so much. This is just what I needed and CM is better than mm. New subject: is there a way to set the space between the records when they are printed? MS Access has a row spacing dialogue in the print preview setup tool bar. (Sorry, I'm obviously very new to LibreOffice.)

pawinda gravatar imagepawinda ( 2019-06-07 09:29:21 +0200 )edit

Just to clarify, I need 1CM between the records as they print.

pawinda gravatar imagepawinda ( 2019-06-07 09:30:05 +0200 )edit

If you have another question, please post a new one.

Opaque gravatar imageOpaque ( 2019-06-07 10:36:22 +0200 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2019-06-07 10:35:09 +0200

Opaque gravatar image

Hello, (Answer just for the records)

The only option I see is to change the Locale at Tools -> Options - Language Settiings -> Languages -> Category: Language Of -> Option: Locale setting to a variant of English [e.g. English (UK)], where the default is using a decimal system (this also doesn't allow to change the ruler showing mm but shows cm).

Any other requirement should be filed to an enhancement request.

edit flag offensive delete link more

Comments

@pawinda

As you have been helped, please help others to know the question has been answered by clicking on the ✔ in upper left area of answer which satisfied the question.

Ratslinger gravatar imageRatslinger ( 2019-06-08 01:20:50 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-06-06 11:40:46 +0200

Seen: 57 times

Last updated: Jun 07