Ask Your Question
0

Is there a hack to change the context menu execution character for Change Case? [closed]

asked 2013-06-30 02:48:04 +0100

pgannon gravatar image

It irritates the h@ll out of me that both Copy and Change Case are executed with the character "c" and I have to choose which one I want. In the Windows world Copy is almost universally executed with "c".

Since I can't edit a context menu, does any one know if there is a hack to either

  1. change the execution character for Change Case (it looks like "g" is not being used on this menu), or

  2. remove Change Case from the context menu?

Thanks.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-03 01:46:55.371070

2 Answers

Sort by » oldest newest most voted
1

answered 2013-06-30 03:17:22 +0100

m.a.riosv gravatar image

I'm sorry, but I do not understand the issue.
·Copy is under Menu/Edit and Change case is under Menu/Format.
·Copy is Crtl+C and Change case has not default keystroke.
What do you need to choose?

edit flag offensive delete link more
0

answered 2013-06-30 06:30:51 +0100

pgannon gravatar image

In Writer when you right-click in a document, a menu appears. This is called a context menu because it is different depending upon the context when you do the right-click. If you have selected text it lists about 16 options including Cut, Copy, and Paste. If you have copied text to the clipboard and simply placed the cursor somewhere in the document, the menu includes Paste but not Cut or Copy. If the clipboard is empty and nothing is selected, none of the 3 appear on the menu.

Because you get no visual feedback when you Ctrl-C to copy selected text to the clipboard, I've gotten into the habit of right-clicking and hitting "c" so that I can see that I've successfully copied the text. This works in virtually EVERY utility that I can think of, except Writer, which also uses "c" to Change Case. Because it's so commonly used, Adobe even changed from using a "y" for Copy to a "c" some years ago, probably from people like me bitching about it. With Writer you can't even hit "c" a second time to jump down to Copy because its Change Case sub-menu uses "c" to Capitalize, so you'll just capitalize all the words you selected. (Thank God for Ctrl-Z!) My version of Writer is Version 3.6.6.2 (Build ID: f969faf). BTW, after doing Help/About I was able to select the version info and do right-click-c to copy it to paste here.

So that's my rant and if anybody knows how to either remove Change Case or have it activate with a "g", please let me know. Thanks.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-06-30 02:48:04 +0100

Seen: 614 times

Last updated: Jun 30 '13