Ask Your Question
0

Removing autocorrection entry doesn't do anything

asked 2019-06-12 06:54:45 +0200

Oltarus gravatar image

Hello,

The default version of LibreOffice in French comes with common typos and diactritics corrections in the autocorrect list. It still uses the "old" orthograph from pre-1990, though.

Although the old school way of writing is still accepted, I prefer using the new one. But alas, some of the words I write are "corrected" to the old version. It is for example the case for "apparait" that is corrected to "apparaît" (circumflex on the i). I want to keep the word as I type it.

  • I went to AutoCorrect tools, selected the corresponding line and deleted it, but the correction still applies.
  • I did the same to all the other French languages (there are a few localizations), but nothing changed.
  • Of course, I restarted LibreOffice, I even tried to power cycle my computer, but nothing works.

How can this happen? Where does LibreOffice get the replacement rule? Is there some kind of cache I should empty?

Versions: LibreOffice 6.1.5.2 on Fedora 29.

Thanks in advance!

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2019-06-12 13:49:54 +0200

RGB-es gravatar image

See this bug report:

Bug 96787 - AutoCorrect: After Removal of Replacement Entry the Replacement Itself is still Performed.

edit flag offensive delete link more
0

answered 2019-06-12 09:16:43 +0200

gabix gravatar image

updated 2019-06-12 13:41:53 +0200

Autocorrect / autoreplacement items can be found both in the user profile and in the program directory such as <install path>/share/autocorr/. Search for files such as acor_fr.dat and acor_fr-XX.dat (XX for country codes), remove as necessary.

Try replacing your acor_fr_FR.dat with the one I attach here (rename the file first):

acor_fr.dat.odt

Does it help?

edit flag offensive delete link more

Comments

If I remove it, it just reinitialize the preferences and "connait"→"connaît" appears again! My problem is that even though I remove it from the list (and thus create an acor_fr-XX.dat), the replacement still applies.

Oltarus gravatar imageOltarus ( 2019-06-12 13:22:12 +0200 )edit

I can't reproduce. If I remove acor_fr.dat, all French autocorrect entries are gone and apparait does not turn into apparaît, if I restore the file, autocorrect restores. Maybe, you have some permission issues.

gabix gravatar imagegabix ( 2019-06-12 13:35:31 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-06-12 06:54:45 +0200

Seen: 28 times

Last updated: Jun 12