Ask Your Question
0

Spreadsheet will not retain cell format. IE-text

asked 2019-06-17 20:09:43 +0200

Sam555 gravatar image

I am trying to develop a date base, batch mailing, envelopes, form letters, customer management system for a small ministry. I have the data base, partner (customer) table, data entry form, queries, etc done.

Currently I am working on the batch envelope mailing. I can do a query and get a list of partners based on whatever criteria they want for any particular batch mailing.

Once I have the query I need to convert that into a calc spreadsheet for writer to recognize the partner list for the batch envelope printing. Here is where I am having a problem. The partner table shows the zip cell / field as text. I can set the new blank spreadsheet zip cell as text, save, close reopen etc, but when I copy and paste the data from the query into the blank spreadsheet the zip field auto magically changes to a number field. The issue is that some zip codes have a leading zero. This leading zero is dropped when pasting. I need the field to retain leading zeros. If I manually change the cell format and add in the missing leading zeros it will then hold the text format. That is more manual work and understanding then the ministry people would be comfortable with. How can I copy the query results into a spreadsheet and retain the text formatting in the zip field? Or is there a different approach that would be better?

Any help will be very appreciated.

Also once I get the functionality down even if convoluted I would absolutely entertain hiring someone who could program / write macros, etc to streamline and smooth the system out gor

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2019-06-17 21:57:20 +0200

Sam555 gravatar image

I will give this a try. Thanks

edit flag offensive delete link more

Comments

Please use the comments.

m.a.riosv gravatar imagem.a.riosv ( 2019-06-17 22:30:39 +0200 )edit
0

answered 2019-06-17 21:04:06 +0200

Lupp gravatar image

An ordinary Copy-Paste sequence (Ctrl+C, Ctrl+V) will always try also copy and paste the format of the source (if applicable). Use Ctrl+Shift+V to "Paste Special ...". You may get prompted to select a "flavour". Select something like "Values only" or "Unformatted text".

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-06-17 20:09:43 +0200

Seen: 20 times

Last updated: Jun 17