Ask Your Question

All my forms have become small

asked 2019-06-18 20:06:48 +0200

dougmn gravatar image

I have a database that I use occassionally. When I opened it today and tried to open a form, I got a message that the JRE was missing. I resolved that, and when I opened the form, everything (fonts, all the controls) was way smaller than it should be. I checked the other forms for the database, and this happens with all of them. Also, on some of them I have a macro which causes the form to go to a new record when opened, and now I am getting error messages that the script could not be found.

Any ideas about what happened, and how to fix it?

edit retag flag offensive close merge delete


Version: Build ID: libreoffice- CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; Locale: en-US (en_US.UTF-8); UI-Language: en-US Calc: threaded

dougmn gravatar imagedougmn ( 2019-06-18 20:07:27 +0200 )edit

1 Answer

Sort by » oldest newest most voted

answered 2019-06-18 23:16:27 +0200

Ratslinger gravatar image

updated 2019-06-18 23:29:18 +0200


The Zoom factor has changed. This can be changed in a couple of ways:

  • From menu of open form View->Zoom select 100%

  • On Status Bar (if off, the from menu View->Status Bar) zoom slider in lower right corner - slide to desired view.

Now you state this is on all forms. There are outstanding bugs regarding Form sizes and such not being retained. This started as a regression in v6.x - see Bug #115619 and since then other further regressions have occurred. Outstanding problem for over a year now and no fix in sight!

So what is happening is that if one form in Base gets modified with zoom level - all forms in all Base file forms get the same change. Only method to control this currently is by use of macros (zoom and form size/position).

Also, surprisingly (although a Base form is a Writer doc), if the zoom factor was modified on a Writer doc, this will affect Base forms also but not other Writer docs. Writer docs still are able to reset to their saved configuration! This is possibly where original bug(s) came from.

edit flag offensive delete link more


Thanks. Changing the zoom back to 100% fixed it. I do suspect that having reduced the zoom in writer at some point affected the forms in the database.

dougmn gravatar imagedougmn ( 2019-06-19 05:01:04 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2019-06-18 20:06:48 +0200

Seen: 51 times

Last updated: Jun 18 '19