Ask Your Question
0

Why these symbols (grayed spaces)

asked 2019-06-22 01:04:51 +0200

mraamohamed gravatar image

updated 2020-08-04 23:53:01 +0200

LeroyG gravatar image

I am new to Libre Office, I am a convert from MS Office 2016. I just hate the big boys telling us what we can do and can not do, and I see libre office is evolved, so I see all the time these symbols (see attached pic) in my documents, can I turn them off or is there something wrong, or am I just too anal retentive.

image description

edit retag flag offensive close merge delete

Comments

When you print the document, do the symbols also appear in the printed version?

ve3oat gravatar imageve3oat ( 2019-06-22 01:33:29 +0200 )edit

Not sure as I do not print a whole lot. Maybe I am just being to anal retentive.

mraamohamed gravatar imagemraamohamed ( 2019-06-22 02:40:53 +0200 )edit

I don't think so. The marks seem to signify any special formatting (like bold) or the use of special characters (like ellipsis). I don't know how to turn them off, but you might not want to turn them off as such "flags" do have their uses (!) when editing a document.

ve3oat gravatar imageve3oat ( 2019-06-22 03:16:59 +0200 )edit

Yea you are right not turn off, but the only thing I saw that they were doing in this document was (a space) but there is no grammar or spelling error, again maybe I am just to Anal Retentive thinking I am still in Word when in fact I have moved on to better things and just need to learn the NEW way of doing things......

Thanks for your answers #ve3oat

mraamohamed gravatar imagemraamohamed ( 2019-06-22 03:20:03 +0200 )edit

2 Answers

Sort by » oldest newest most voted
2

answered 2019-06-22 05:37:59 +0200

The spaces with grey background are most likely non-breaking spaces (U+00a0, inserted with Ctrl+Shift+Space), or maybe some other special spacing mark (not usual space). You may check the character Unicode code in Writer by putting cursor right to the right of the character in question, and pressing Alt+X (pressing it second time converts the revealed code back to the character).

edit flag offensive delete link more

Comments

3

Why these symbols

.

The text (obviously) was copied from the internet. There we find lots of non-breaking spaces instead of normal spaces because browsers "shrink" more than one space into one single space (HTML editors sometimes replace spaces with non-breaking spaces). For that reason the special "character"   is used. For more information search for html space on the internet.

Grantler gravatar imageGrantler ( 2019-06-22 08:55:55 +0200 )edit
1

answered 2020-05-08 20:21:57 +0200

LeroyG gravatar image

If do you seek only to hide the gray color, you can use Ctrl+F8 (the same that menu ViewField shadings.

If do you seek to raid off with the non-breaking spaces, Search "[:space:]" and Replace with a space " " (without quotes).

edit flag offensive delete link more

Comments

1

They probably are non-breaking spaces, not fields. Hiding them is controlled by View>Formatting Marks. The best solution is to replace them with ordinary spaces because they are usually not typed intentionally (average users don't understand the difference).

ajlittoz gravatar imageajlittoz ( 2020-08-05 08:20:50 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2019-06-22 01:04:51 +0200

Seen: 274 times

Last updated: Aug 04 '20