We're currently migrating from Ask to Discourse, read the details here

Ask Your Question
0

(Ubuntu 13.04) LibreOffice 4.0.2.2 ignores SAL_ENABLE_FILE_LOCKING [closed]

asked 2013-07-03 14:37:37 +0200

chapaswork gravatar image

updated 2021-07-02 14:41:11 +0200

Alex Kemp gravatar image

I'm running Ubuntu 13.04. LibreOffice 4.0.2.2 ignores the SAL_ENABLE_FILE_LOCKING variable, which I edit in the /usr/lib/libreoffice/program/soffice script to disable file locking. Even if I comment or set this variable to 0, the lock file is created. Is this a bug, or I should modify some other option to disable file lock creation? Thanks!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2021-07-02 14:41:28.226752

2 Answers

Sort by » oldest newest most voted
0

answered 2015-08-30 00:56:55 +0200

ealthuis gravatar image

My solution has been to edit /usr/bin/soffice and comment out the follwing lines:

SAL_ENABLE_FILE_LOCKING=1 export SAL_ENABLE_FILE_LOCKING

My problem was a NFS server and it's clients, when a client opened a LO file,it is locked to all others. Unfortunately it remains so even though nobody is using it.

The above fix corrected the problem for me, this may not be right for others. I am the owner and sole user of the server and the clients.

edit flag offensive delete link more
0

answered 2013-07-03 15:59:03 +0200

oweng gravatar image

Are you using the PPA or website verion of LO? The Ubuntu-supplied version may be different. Perhaps try running grep over /opt/libreoffice4.0/program/ to see if it the variable is set elsewhere. The gengal, spadmin, and unopkg scripts all contain the same variable. but none of those should be related.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-07-03 14:37:37 +0200

Seen: 426 times

Last updated: Jul 03 '13