Ask Your Question
0

Two-column index - page numbers not visible

asked 2019-07-08 17:00:35 +0100

EdB gravatar image

updated 2019-07-08 17:02:21 +0100

Libre Office Writer v6.0.7.3, Linux Mint 19.1. Trying to create a two-column index, but page numbers are not visible. Single column works fine.

image description

(image link if the above does not work https://imgur.com/GTg0TLz)

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2019-07-08 18:39:51 +0100

ajlittoz gravatar image

Two possible causes to this misbehaviour:

  • Index layout misconfiguration

    Right-click in your index and Edit Index. Got ot the Entries tab. Click successively on the levels 1, 2 and 3 to check the layout which is be default E T #. Click on T to display its properties. You may have a fixed tab stop valid for full width, but too large for 2-column. The traditional setting is to check Align right so that the position self-adjusts to column width.

  • Style misconfiguration

    Index entries are styled Index 1 to Index 3 (one paragraph style per level). Open Index 1 (and others) definition and go to Tabs tab. If you have tab definitions, they may override the index layout (though layout has priority over style, but sometimes …). Remove any tab definition to make sure.

If no suggestion cures the problem, update your question to give further technical information or attach a sample file. Don't use an answer for something which not a solution.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Comments

First, thanks for responding. I am thinking that what my issue here might be is that this file was an import from an MS Word document, and there there is something odd about the way the import gets handled. I have encountered some peculiar problems with indexes and formatting when I do this with the specific types of documents I am working with. If I create a new document as an .odf file with the same content as the .doc file, then the indexing displays just fine, no brainwork required. So I think what I am going to do is just re-create the file from scratch (it is not large, fortunately) and get it done correctly right from the start. So I will just hold off looking for a fix for this for the time being.

EdB gravatar imageEdB ( 2019-07-09 02:20:50 +0100 )edit

M$ Word only knows of paragraph styles. This means all extra formatting is translated as "direct formatting" in LO Writer or as a plethora of single-usage character styles. Matters become very complicated when it comes to second level features like index table (generated from entries collected in the text).

ajlittoz gravatar imageajlittoz ( 2019-07-09 07:55:31 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-07-08 17:00:35 +0100

Seen: 39 times

Last updated: Jul 08