Ask Your Question
0

6.2.5 crashes on generic CentOS 7 install

asked 2019-07-11 21:25:36 +0200

selway gravatar image

I downloaded the latest 6.2.5 RPM distribution (64bit) from the Libreoffice repository, extracted the tar.gz and from within the RPM directory, installed it like this:

yum localinstall *rpm

This seemed to proceed smoothly and yum did not report any errors or missing dependencies. Next, I tried to open LibreOffice, first from the created icon in my KDE menu, but that crashed (the splash screen shows up for a second and then disappears and nothing else opens). Next, I tried to execute scalc, swriter, and soffice directly from /opt/libreoffice6.2/program/soffice, but that had the same effect. I tried to find out if there were any missing dynamic libs, like this:

ldd ./soffice.bin | grep found

which should show any missing libs, but nothing is missing. Any other suggestion? The interesting thing is, when I installed 6.1.x I don't have the problem, but I do get a notice that the previous time I opened the program it crashed. I sent the crash report, which you can find here:

The crash report was successfully uploaded. You can soon find the report at: crashreport.libreoffice.org/stats/crash_details/0074bc14-59d0-4454-8b4a-f2ec922ef7e2

Thanks!

edit retag flag offensive close merge delete

Comments

Did you try to reset user profile?

Mike Kaganski gravatar imageMike Kaganski ( 2019-07-12 07:55:41 +0200 )edit

Just installed 6.2.5 using packages from libreoffice.org on my CentOS 7 test system and cannot reproduce the error and - strange enough - the crashreport above states

Version Version: 6.1.4.2

Opaque gravatar imageOpaque ( 2019-07-12 13:00:02 +0200 )edit

I have the problem as well, and the answer below also worked for me. The program attempted to submit the dump files, but the service complained that they missed version info.

Appears to be fixed in LibreOffice 6.3, I just installed it and it's working.

jfuqua gravatar imagejfuqua ( 2019-08-08 19:46:51 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-07-12 17:14:09 +0200

selway gravatar image

Executing 'SAL_USE_VCLPLUGIN=gen /opt/libreoffice6.2/program/soffice' from the command line circumvents the problem and 6.2.5 loads correctly when I do that. But I am still not sure what the issue is.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-07-11 21:25:36 +0200

Seen: 53 times

Last updated: Jul 12