Ask Your Question
0

missing footers, footers changing. I seem to have ended up with lot of converts - no idea what they are. cant get footer to do uniform default throughout document. thanks for help. T t

asked 2019-07-16 17:08:25 +0200

tomas gravatar image

updated 2019-07-16 17:15:33 +0200

No matter how many times I try , I end up with footers doing different things. I've clicked, same as first page, Ive tried same as left and right. It all goes well until so far down the document then it either disappears or the page number disappears. This document is a novel of 437 pages - no pictures just text. I can't work it out at all. I've also cut and paste and opened to a new doc, adding the footer. Starts off well then goes wrong. thanks for any help, T

edit retag flag offensive close merge delete

Comments

Footers (and headers too) are attributes of page styles. They can change only if the page style is changed.

At the location where this happens, have you a manually inserted page break? If so, remove it. Does it cure the problem?

Answer to these questions with a comment or an edit to your own question. Don't use an answer.

Also mention LO version and OS.

ajlittoz gravatar imageajlittoz ( 2019-07-16 17:15:27 +0200 )edit

thanks for reply. I've added page breaks. Ive just removed one that resulted in page getting a footer - other pages around it have footers up to page 11 - then i have convert style 3 and noting on the footer. all my attempts to gte a default style have failed. there are now no footer text or numbers down to page 240. Do I just need to reformat the whole thing? I've no idea what I've done to get to this. So my reformatting may be the problem. I had this same problem last year so changed program.

tomas gravatar imagetomas ( 2019-07-16 17:46:44 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-07-16 18:04:52 +0200

ajlittoz gravatar image

From your comment, your manual formatting may be the problem. Though you may be in a hurry, learn how to use styles. Styles are base bricks in Writer. They appear everywhere: paragraph, character, frame, list and page, contrary to other applications, like M$ Word, which only have paragraph styles, forcing the user to heavily use manual formatting.

A good start is the guide freely downloadable from the Libre Office site.

Manual formatting (called direct formatting in Writer) goes unnotices and is easily forgotten. Then you patch over and over again trying to fix the situation but it gets worse.

Two ways to temporarily fix the issue:

  • the hard way

    1. select your whole document (Ctrl+A)
    2. open the "stylist" with F11 (unless you're on a Mac)
    3. click on the fourth icon in the toolbar (Page Styles)
    4. double-click on Default Style

    This does not remove the page breaks but forces all pages to the same style. However, some direct formatting may have precedence and some "errors" may remain.

  • the soft way

    Hunt for all your page breaks and remove them one by one.

When editing your document, make a difference between Insert>Page Break (Ctrl+Return) and Insert>Manual Break. The former does not change the page style, thus you keep the same header/footer. The latter allows to change the page style and to reset the page number. This is probably what you used.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Comments

I think you may have identified the problem - me! - In all the packages I've used over the years I've never had a problem of creating extra styles without knowing it. My, 'solutions', appear to have added to the problem. Thanks, T

tomas gravatar imagetomas ( 2019-07-16 22:15:10 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-07-16 17:08:25 +0200

Seen: 27 times

Last updated: Jul 16