Ask Your Question
-3

Here we go again: "JRE defective" But it's LibreOffice that's defective! [closed]

asked 2013-07-13 00:59:11 +0200

RBV gravatar image

updated 2015-09-12 05:06:27 +0200

Alex Kemp gravatar image

So I made the mistake of upgrading to LibreOffice 4. And so once again when I start Libre office I get the useless message, "LibreOffice requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - LibreOffice - Java."

For a start, the JRE is NOT defective. It currently runs Eclipse, jEdit, and pretty much any other program that wants a JRE. Only LibreOffice continues after all these years to be incompatible with most JREs.

The second problem is that the error message is uninformative. If LibreOffice is unhappy with my currently working JRE, then exactly which version and type (32-bit or 64-bit) does His Highness LibreOffice require? "Another version" is pointlessly stupid guidance.

Thirdly, LibreOffice 4.0.4.2 no longer contains a Tools - Options - LibreOffice - Java menu choice. The Java option so helpfully described in the long-obsolete error message created for OpenOffice 0.1 has been replaced by Advanced. Sigh…

This specific OpenOffice / LibreOffice problem has existed for far, far, far too many years. I'd report it as a bug, but I see that reporting LibreOffice errors would require me to create another separate web account simply to tell the LibreOffice developers to put an end to this stupid "JRE defective" finger-pointing when in fact it's LibreOffice that has the problem.

So, does anybody just so happen to know which JRE version and type (32-bit or 64-bit) I need to acquire just to satisfy LibreOffice 4? Or should I simply roll back to the formerly working version and permanently forgo upgrading to any newer, yet presumably still not-improved, versions of LO? (Because the evidence indicates that the LO developers are unable to fix LO's JRE compatibility problem; or even simply update the error message so that someone can take informed corrective action…)

Yeah, yeah, I know — LO is free so one can't expect it to work properly. Got it, thanks.

Cheers & thanks, RBV SFO

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-02-19 11:34:40.322171

4 Answers

Sort by » oldest newest most voted
1

answered 2013-07-14 09:58:25 +0200

L-user gravatar image

updated 2013-07-14 09:59:06 +0200

I am using LibreOffice 4.0.4.2 and using Java 7 update 25 and I have never had any problems like you described on Windows XP sp3 (32-bit). So the problem may not be in Java or LibreOffice but in your system configuration...

LibreOffice developers are making a lot of effort to remove Java dependency from LibreOffice in exactly the same reason you are having. LibreOffice developers can't control the JRE that is or even it isn't installed on Windows computers. So they are rewriting code from Java to Python (embed version of Python is distributed with LibreOffice) and since this is not 100% complete there may be problems like you are facing.

edit flag offensive delete link more
2

answered 2013-07-13 02:40:03 +0200

m.a.riosv gravatar image

Java selection is now in:

Menu/Tools/LibreOffice/Advanced.

edit flag offensive delete link more
1

answered 2013-07-13 04:59:38 +0200

oweng gravatar image

Your JRE must match your LO install in terms of whether it is 32 or 64bit. LO only comes in a 32bit version for Windows, so on that platform you must use a 32bit JRE.

edit flag offensive delete link more

Comments

1

Under Windows you select which JVM to use from Tools\Options\LibreOffice\Advanced. A 32 bit JVM can be downloaded from here: http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-1880261.htm Select a Windows x86 version as these are 32 bit. On Windows 7 by default it will install in c:\Program files (x86)\Java with all the other 32 bit applications. You may also have 64 bit versions which would have installed in c:\Program Files\Java and these will not work with LibreOffice. Make sure you select a 32 bit version as described above and the macros should work.

dmc7337 gravatar imagedmc7337 ( 2014-02-21 01:25:10 +0200 )edit
0

answered 2014-02-21 19:41:25 +0200

DannyB gravatar image

I have this same problem.

Using a 32-bit Java is NOT AN OPTION.

I need the 64-bit Java because I need to give Eclipse 6 GB of memory, and other processes more than 4 GB of memory. (I have 32 GB of memory.)

LibreOffice offers 64-bit versions for Mac OS and Linux. Why not for Windows?

There is a legitimate need to be able to use 64-bit Java. If I am not able to use LibreOffice, or all of its capabilities, then I will just have to live with that. Giving up 64-bit Java is simply NOT AN OPTION. My company provides me Microsoft Office, and I could live with that, but I've liked LibreOffice, and formerly OpenOffice.org for many years.

edit flag offensive delete link more

Comments

1
Alexander Wilms gravatar imageAlexander Wilms ( 2014-02-21 20:17:38 +0200 )edit

"I need to give Eclipse 6 GB of memory ..." I do not see what this has to do with LO. When you are producing LO documents that are consuming close to 4GB of RAM, then you will have cause for concern. You may already be doing this, but you do not indicate this. As indicated up-thread it is quite possible to install both 32bit and 64bit Java to suit the respective application requirements. The related enhancement for porting LO to a 64bit build for Windows is fdo#61683.

oweng gravatar imageoweng ( 2014-02-22 02:33:11 +0200 )edit

@oweng Thank you for the mention that it is possible to install both 32bit and 64bit Java. I had somehow missed that. In my several years of using Java, that capability had escaped me. That completely solves my problem. I can now access BeanShell macros, etc within LibreOffice. And no, I do not need a Java process associated with LibreOffice to exceed 4 GB of memory. So this is completely satisfactory. Unless I one day write an extension that needs a lot of memory. :-)

Thank you again

DannyB gravatar imageDannyB ( 2014-03-11 19:07:34 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2013-07-13 00:59:11 +0200

Seen: 19,640 times

Last updated: Feb 21 '14