Ask Your Question
0

menus are transparent after recent update

asked 2019-07-21 08:56:36 +0200

NginUS gravatar image

updated 2019-07-21 09:21:29 +0200

ebot gravatar image

I'm on Linux Mint 18.3 which is Ubuntu 16.04 LTS, & this past week my LibreOffice updated to version 1:6.2.5- as per this PPA: deb http://ppa.launchpad.net/libreoffice/ppa/ubuntu xenial main

Prior to doing so (most) everything in the LibreOffice apps worked fine, with the exception of the scrollbar being the same color as the scrollbar background- but it was tolerable.

However, after it updated a few days ago, now all the menus are suddenly transparent, & as such are unusable:

Screenshot

My DE is KDE Plasma, & it has a theme which makes the panel & menu semi-transparent, & up until this week, LibreOffice didn't inherit any of those settings. But now it appears to all of a sudden. I poked around all sorts of settings, & haven't found a way to fix it. Would be nice to be able to fix the scrollbar issue as well- this menu issue is quite horrendous at the moment though, & is the priority.

Thanks in advance.

edit retag flag offensive close merge delete

Comments

Wow...that'd be kinda cool if it didn't render LO useless! :D Out of curiosity have you tried changing the KDE theme to something else, just to see what happens?

gtomorrow gravatar imagegtomorrow ( 2019-07-21 09:50:18 +0200 )edit

So I tried changing it & somehow everything I'm able to change it to has some sort of transparency, which is not how I remember it when I initially set it up so long ago. As such, the LibreOffice menus did not change, even when the transparency level's opaqueness changed. The menus were always exactly the same as my original screenshot.

It seems I had been using a customized (& unsaved) variant of the 2 base desktop themes I have installed (Breeze & Breeze Dark). Now everything's borked- will have to figure out how to get back to what it was before I started tinkering. :-(

NginUS gravatar imageNginUS ( 2019-07-21 10:22:44 +0200 )edit

Look at Help → About LibreOffice which VCL plugin is being used. From the screenshot, it seems that it's using the new (and for 6.2, still unstable) KDE plugin. If that the case, check your package manager and install the GTK3 LibreOffice package, possible uninstalling the KDE one (fortunately, the KDE plugin for VCL works a lot better on the upcoming 6.3, though)

RGB-es gravatar imageRGB-es ( 2019-07-21 10:24:29 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2019-07-21 10:31:31 +0200

NginUS gravatar image

As per RGB-es:

install the GTK3 LibreOffice package, (...) uninstalling the KDE one

Problem solved! Thanks...

edit flag offensive delete link more
0

answered 2019-07-23 23:02:54 +0200

hps gravatar image

Hi,

on Fedora 30 I did

dnf install libreoffice-icon-theme-papirus.noarch libreoffice-kf5.x86_64 libreofficekit-devel.x86_64

This fixed the transparency. Though I did not check which package fixed the problem. Those just looked reasonable :-)

Greetings, HP

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-07-21 08:56:36 +0200

Seen: 100 times

Last updated: Jul 23