Ask Your Question
0

LibreOffice Calc - read-only files

asked 2019-07-25 15:48:08 +0200

mtmcdonough gravatar image

Hi. We have a number of raspberry pi devices that access files on our network storage device. The pi's have only read access to the various files: jpg, pdf, doc, xls, etc.

When the clients open an xls file with LibreOffice Calc, they get a warning message about that "the document in use is locked" and are asked how they want to open the file. Of course, they select read-only.

Is there an option to have Calc always open xls files in read-only mode without asking the question about a locked document? I am trying to save our clients a step in opening the xls files. Thanks, in advance.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2019-07-25 22:52:12 +0200

Ivan Baldo gravatar image

Have you tried localc --nolockcheck file.xls?

Have you tried localc --view file.xls?

If you mean that they double click on files then you need to change the MIME association to use one of those options above.

On a Debian Stretch system you may try to edit:

/usr/share/applications/libreoffice-calc.desktop
/usr/lib/libreoffice/share/xdg/calc.desktop
/usr/lib/mime/packages/libreoffice-calc

After editing those files, you may need to run some of these commands:

update-desktop-database
update-mime
update-mime-database

Or you may try to do it graphically in your desktop environment.

edit flag offensive delete link more

Comments

1

Thank you. The options you provided worked perfectly! Thanks, again!

mtmcdonough gravatar imagemtmcdonough ( 2019-08-01 23:29:17 +0200 )edit

Great! Please mark the answer as correct then, thanks!

Ivan Baldo gravatar imageIvan Baldo ( 2019-08-07 01:37:06 +0200 )edit
0

answered 2019-07-26 16:48:11 +0200

mtmcdonough gravatar image

updated 2019-07-30 20:20:29 +0200

Thank you. The options you provided worked perfectly! Thanks, again!

edit flag offensive delete link more

Comments

Please use add a comment for comments and thank you messages instead of adding them as answer to the the original question, which it is not. Thank you.

erAck gravatar imageerAck ( 2019-08-01 22:32:44 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2019-07-25 15:48:08 +0200

Seen: 56 times

Last updated: Jul 30