Impress/GTK+ 2: how to make selected text go to primary clipboard instead?

asked 2019-07-26 17:40:20 +0200

When I select text in LibreOffice Impress it replaces whatever I had on the CLIPBOARD clipboard. It should go to the PRIMARY clipboard. Using GTK+ 2.

Any ideas on how can I change this? I don't want to use GTK 3 because it's usage by LibO is too buggy.

Thanks, Octavio.

edit retag flag offensive close merge delete

Comments

And that should be a problem of LibreOffice now?

ebot gravatar imageebot ( 2019-07-26 18:30:46 +0200 )edit

See tdf#104717 for a ~similar problem (involving PRIMARY and CLIPBOARD) - but it's for KDE and its "Synchronize contents of the clipboard and the selection" setting under "Clipboard contents". Not sure if there exists something like that.

OTOH, you wrote:

I don't want to use GTK 3 because it's usage by LibO is too buggy

but you didn't mention if you had tried GTK 3 (temporarily) to test if the problem still is there; nor did you mention if you meant GTK plugins of LibreOffice or system GTK; which LO version you use; and even which OS you use...

Mike Kaganski gravatar imageMike Kaganski ( 2019-07-27 00:25:08 +0200 )edit

Also possibly related: tdf#126316 - but it was a problem in 6.3 series prior to 6.3.0.2...

Mike Kaganski gravatar imageMike Kaganski ( 2019-07-27 02:01:29 +0200 )edit