Ask Your Question
0

How do i stop Calc starting with 'design mode' controls turned on

asked 2019-08-06 10:35:14 +0200

brucewatt gravatar image

updated 2019-08-06 13:35:06 +0200

Every time I open Calc, the 'Design Mode' under the 'controls' icon are turned on. How do I turn this off? It does not matter if I turn this off and then save and close the file. It turns itself on when opening again.

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2019-08-06 14:11:15 +0200

updated 2019-08-06 14:11:36 +0200

Uncheck ToolsFormsOpen in Design Mode.

edit flag offensive delete link more

Comments

Brillant! thank you. I know it would be something simple, I just could not find it. Thank you again

brucewatt gravatar imagebrucewatt ( 2019-08-06 14:35:15 +0200 )edit
0

answered 2021-04-07 14:09:58 +0200

thurston gravatar image

updated 2021-04-08 17:24:26 +0200

1st step: place this in your macro "My Macros"

Sub on_ApplicationStart( oEvent As Object )
   REM Should be connected to the "Start Application" event of LibreOffice.
   rem ----------------------------------------------------------------------
   rem define variables
   dim document   as object
   dim dispatcher as object
   rem ----------------------------------------------------------------------
   rem get access to the document
   document   = ThisComponent.CurrentController.Frame
   dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

   rem ----------------------------------------------------------------------
   dim args1(0) as new com.sun.star.beans.PropertyValue
   args1(0).Name = "SwitchControlDesignMode"
   args1(0).Value = false

   dispatcher.executeDispatch(document, ".uno:SwitchControlDesignMode", "", 0, args1())
End Sub

2nd Step: assigning the macro to a common event Using the menu customize, assign this macro to the event "Modified Status was changed". Then, each time you open an ods and make any little modification to the file, the "Design Mode" will be deactivated. (simply place a space in a blank cell, and the trick is done). I apply this macro also to Start application” + “New Document” + “Open Document”.

edit flag offensive delete link more
0

answered 2019-08-06 10:50:26 +0200

ebot gravatar image

Close the Form Controls toolbar. Save the file.

edit flag offensive delete link more

Comments

Thank you for your reply Sorry, that does not work for me. it always goes into design mode when reopening.

brucewatt gravatar imagebrucewatt ( 2019-08-06 12:34:44 +0200 )edit

I've got the same issue. Regardless of what I do, the calc sheet opens in design mode.

BarryO gravatar imageBarryO ( 2019-08-21 23:50:06 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2019-08-06 10:35:14 +0200

Seen: 244 times

Last updated: Apr 08