Ask Your Question
1

Why can I not open csv file as comma delimited? [closed]

asked 2013-07-18 16:24:53 +0100

netmarketer gravatar image

updated 2015-08-29 21:10:53 +0100

Alex Kemp gravatar image

In the previous version, when I wanted to open a csv file, I was able to select Comma as the separator and it would show the fields in the lower portion of that dialogue box. Since I upgraded to 4.0.4, the fields are merged into 1, with an arrow (->) inserted between the fields. When the file is opened, all fields are in 1 column.

Here is how the dialogue box looks when Comma is selected (2 files): http://i.imgur.com/aynKhff.jpg Each file has 2 fields. The file showing 2 fields correctly was created with the previous version of LO. The file showing the merged 2 fields was created with the latest version.

Is this a bug?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2016-03-05 19:57:03.160760

4 Answers

Sort by » oldest newest most voted
1

answered 2013-07-19 13:19:42 +0100

oweng gravatar image

@netmarketer, I have added a link to your bug in your answer, but unfortunately (according to the comments in the bug report) your original file contains Tabs as the separating characters and not Commas. If you are wanting to change these characters from one type to another it is often best to do this externally to LO, however it can be done using these steps:

  1. Import your CSV file into Calc using Tab as a separating character.
  2. File > Save As... > select the File type of "Text CSV".
  3. Click Save button.
  4. Confirm "Use Text CSV format".
  5. On the Export Text File dialog, set the Field delimited to a comma and other settings as required.
  6. Click OK.

If this solves your issue, please RESOLVE your bug as NOTABUG. Thanks.

edit flag offensive delete link more
0

answered 2013-07-18 17:35:29 +0100

carnendil gravatar image

It seems you should report a bug. Check also the question "How do I see if a bug has already been reported?" and the wiki on details for bug reports.

edit flag offensive delete link more
0

answered 2013-07-18 18:20:18 +0100

netmarketer gravatar image

updated 2013-07-19 13:08:54 +0100

oweng gravatar image

Thanks. I did eventually report the issue as a bug.

EDIT: fdo#67049 is the related bug.

edit flag offensive delete link more

Comments

Please edit your answer and report the bug number according to the following instructions. You can then proceed to accept an answer by clicking on the little check-mark to the left of the answer. Voting is accepted, too :)

carnendil gravatar imagecarnendil ( 2013-07-18 18:31:20 +0100 )edit
0

answered 2014-11-04 17:18:44 +0100

Alw gravatar image

I had the same problem, this is how I handles it: Save the file again with a .csv extension. Double click to open --> everything goes from here as it used to (you get to choose the delimiter and see a preview). B.T.W I'm on Ubuntu 14.04

Good luck, hope this helps someone!

Al

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-07-18 16:24:53 +0100

Seen: 7,483 times

Last updated: Nov 04 '14