Ask Your Question
0

odt and ott files saved in Windows missing 1st page header when opened in Linux

asked 2019-08-13 00:46:46 +0200

nutsofasst gravatar image

Created v.6 Writer files in Windows with a different 1st page header. When opened on computer running Linux, the files are missing the 1st page header and the header setting for "Same content on first page" is checked. Win v.6.2.4, Linux v.5.1.6. Reverse is not true: files created on Linux machine keep settings on Win machine.

This is especially concerning because some of these .ott files are for use on OpenOffice at a remote location where I will not be able to correct them.

Any solution? Thanks!

edit retag flag offensive close merge delete

Comments

Did you file a bug report on this? In not, please do.

Mike Kaganski gravatar imageMike Kaganski ( 2019-08-13 07:30:43 +0200 )edit

Win v.6.2.4, Linux v.5.1.6.

@Mike Kaganski - are LibreOffice developers really willing to support / fix a forward compatibilty problem? (Just for my curiosity).

Opaque gravatar imageOpaque ( 2019-08-13 11:14:46 +0200 )edit

It needs evaluating. If it is relatively simple, then why not. Additionally, it's unclear how old are the affected versions (it might be 5.4, or 6.0, or 6.1 actually); and how that affects external compatibility (if they support it: AOO (OP has mentioned it; however I doubt it supporting the LO extension)? MSO?); and how that affects standard compliance (the feature is now part of upcoming ODF 1.3)... so in any case - a bug report is a good thing; and if it deemed unnecessary, the bug report would be closed, with a description, and may be referenced further.

Mike Kaganski gravatar imageMike Kaganski ( 2019-08-13 11:30:24 +0200 )edit

@Mike Kaganski - Bug report filed yesterday. Thanks for your suggestion. This incompatibility has frustrated what I thought would be a simple solution to a issue for some computer-illiterate local-library-supporting volunteers.

nutsofasst gravatar imagenutsofasst ( 2019-08-13 17:06:33 +0200 )edit

The bug report remains "unassigned." I hope finding a workaround doesn't mean it will be ignored. It could still be useful to know why the problem occurs.

nutsofasst gravatar imagenutsofasst ( 2019-08-14 16:20:00 +0200 )edit

What is the # of the report?

OTOH, don't expect that filing a bug will trigger some immediate action. You have done your part notifying developers; it might take some time until the report is tested (if it's reproducible); and when if it is confirmed, it might take some time (e.g., 15 years) till it's fixed :-)

Mike Kaganski gravatar imageMike Kaganski ( 2019-08-14 16:23:01 +0200 )edit
nutsofasst gravatar imagenutsofasst ( 2019-08-17 00:32:43 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-08-13 16:10:29 +0200

gabix gravatar image

Use a separate style for the first page (for example, yes, the built-in First Page) rather than a special header.

edit flag offensive delete link more

Comments

Thanks for the suggestion. I don't see how that would work in a simple-to-understand way for users who simply want to type in content and either print or attach the finished document. The first page header is an image, the header for the following pages has a title and page number.

nutsofasst gravatar imagenutsofasst ( 2019-08-13 17:13:37 +0200 )edit

Create a template. Distribute it among the users. Instruct them to use it when creating new documents.

gabix gravatar imagegabix ( 2019-08-13 19:44:02 +0200 )edit

@gabix - It works! I thought this would cause page 2 to be "page 1" but that's not the case. Thanks for your help!

nutsofasst gravatar imagenutsofasst ( 2019-08-13 21:51:32 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-08-13 00:46:46 +0200

Seen: 28 times

Last updated: Aug 13