Ask Your Question
0

writer: put numbered list to table

asked 2019-08-17 00:38:10 +0200

carnish gravatar image

updated 2019-08-17 00:43:38 +0200

I have a numbered list. I want to create a table of that list so that each item of the list is put to a row and each row has another column.

"Convert text to table", taking tab as separator, will make a table, but then when I add a column, the numbering is continued across the row. I dont' want that. I want the numbering of the row to stay with the leftmost column.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2019-08-17 07:51:00 +0200

ajlittoz gravatar image

updated 2019-08-17 20:04:01 +0200

A numbered list is formatted as such by a specific paragraph style associated to a numbering style (improperly called list style in LO documentation/help) through the Outline & Numbering tab of the paragraph style.

When you Table>Convert>Convert text to table, the cells in the new table keep the paragraph style the text was formatted with. In case the text was a list, all cells are also list items while you want only the first column to inherit the list property.

The fix is easy: select the second column and style it with another style like Table Contents.

In case you direct-formatted your document (without using styles consistently), getting rid of the list attribute may be difficult. Ctrl M (Format>Clear Direct Formatting) is inoperative on this attribute. You must disable the list property with the toolbar button or right-click and Bullets & Numbering>Bullets/Numbering Off. If this step is needed, you have direct formatting. The "correct" procedure is to use strict paragraph styles without "decorating" them with attributes added by keyboard shortcuts or toolbar buttons. Direct formatting always plays nasty tricks on your back.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Comments

In my version Version: 6.2.5.2 Build ID: 1:6.2.5-0ubuntu0.19.04.1 these do not work. What does work is to select the column then right-click, Bullets Numbering/Numbering off. If you add that to your answer I'll tick it and upvote.

carnish gravatar imagecarnish ( 2019-08-17 19:31:00 +0200 )edit

My version is also 6.2.5.2. I select a whole column, change the paragraph style and everything is OK. Note that my initial list was formatted with an ad-hoc paragraph style without any direct formatting (no toolbar button usage). This usually makes a really big difference.

Right-click and "Numbering off" denotes some direct formatting which should be avoided in favour of strict style usage.

ajlittoz gravatar imageajlittoz ( 2019-08-17 19:36:49 +0200 )edit

whatever... :) thx

carnish gravatar imagecarnish ( 2019-08-17 20:24:46 +0200 )edit

You're welcome

ajlittoz gravatar imageajlittoz ( 2019-08-17 20:38:41 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-08-17 00:38:10 +0200

Seen: 23 times

Last updated: Aug 17