Ask Your Question
0

Calc 6.2.5.2 The date shows */*/2019 instead of */*/19 19

asked 2019-08-18 14:40:12 +0200

Donn09 gravatar image

When I type the date in the column as 17/08/19 it's always appeared that way but now in the updated version it will appear as 17/08/2019. How can I get it back to how it was?

edit retag flag offensive close merge delete

Comments

Did you change your locale or some related settings like the default language for documents?
If I do as you described with LibO V6.3.0.2RC under English (UK) locale and Default - English (UK) as the language entry in the 'Numbers' Tab of the cell formatting dialogue, I get what you expected.

By the way: That's very bad. Always format your dates (you have a dedicated column as it seems) as decribed by the code YYYY-MM-DD. This SHOULD be the default format for all locales IMO .
See this cartoon.

I personall have additionally set my Date acceptance patterns: to D.M.. to ease entry a bit regarding old habits. You may use in this place D/M/ e.g.

Lupp gravatar imageLupp ( 2019-08-18 15:22:58 +0200 )edit

You may also consider to edit the subject. The stars are ambiguous and the second "19" at the end is misleading.
If you use an example you will surely choose one that disambiguates against the US style dates (day number > 12).

Lupp gravatar imageLupp ( 2019-08-18 15:29:37 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2019-08-18 16:08:31 +0200

updated 2019-08-18 17:56:17 +0200

Format Cells... / Numbrers

Category: Date

Format code: DD/MM/YY

-----------------------------------------------------------------------------

ATTENTION: If you would like to give more details to your question, use edit in question or add a comment below. Thank you.

If the answer met your need, please click on the ball Descrição da imagem to the left of the answer, to finish the question.

edit flag offensive delete link more
0

answered 2019-08-18 15:43:45 +0200

ajlittoz gravatar image

updated 2019-08-18 16:13:36 +0200

You have to check Tools>Options, LibreOffice General. The setting Yaer (Two Digits) defines the threshold for the century.

If your 2-digit year is below the threshold, then you're in the XXth century (19..). Above the threshold, you're in the current century (20..).

If you want to enter 2-digit XXth-century years, set the threshold to any suitable value for you. Note however this will not correct already entered dates, the feature is active only when typing new dates.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

EDIT

I may not have understood your question. I based my answer on the title. As @Lupp noted, the "19 19" is misleading. Please correct the ambiguity as my answer may not address your question.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-08-18 14:40:12 +0200

Seen: 50 times

Last updated: Aug 18