Ask Your Question
0

Libre office remote files with google authenticator code (six digital pin)

asked 2019-08-23 22:58:09 +0200

marlone36 gravatar image

updated 2020-07-21 19:45:54 +0200

Alex Kemp gravatar image

The libre office remote files has on the google drive is need google authenticator code (six digital pin).

It is not working

image description

I am not sure six digital pin for the authenticator code ? How to fix this problems ?

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
0

answered 2019-11-17 14:45:51 +0200

daifu gravatar image

updated 2019-11-20 16:05:42 +0200

This worked for me. It all has to do with Google apparently. This is what I did to solve Libreoffice's login into Gdrive on my computer. I run DEBIAN 10

  1. Go into GMail
  2. Go to MANAGE YOUR GOOGLE ACCOUNT (it's right upper corner under the icon for your account)
  3. Go to SECURITY
  4. SECURE ACCOUNT
  5. SECURITY ISSUES FOUND - I found Libreoffice listed here
  6. Grant access to Libreoffice (it will ask if you are sure - say YES)
  7. Make sure under Signing in to Google you signin the old fashion way, no phone, no 2 step verification. Plain email and password signin
  8. Turn on Less secure app access
  9. Make sure you are auto signing in into your ONLINE ACCOUNTS in your computer and open a file browser to the Gdrive.
  10. I had to reboot to have everything working

Can someone verify if this works. I will be trying this on my work's computer this week also. Let you know

Yes, tried it on the office computer and it is working fine.

edit flag offensive delete link more

Comments

Hello @daifu,

Have posted about this many times. In years past it has worked for me. Over the past year or so it has not. Every so often the subject arises again and again I test. Today's test was no different. Still does not work with:

Linux Ubuntu 18.04 Mate
LO v6.3.3.2

Tried your process and still no success. Please note that in the past when this did work for me, it was never necessary to have:

auto signing in into your ONLINE ACCOUNTS in your computer.

This should definitely not be needed as it becomes a security issue.

Ratslinger gravatar imageRatslinger ( 2019-11-17 19:13:50 +0200 )edit

Hi @daifu,

Still not works and I am on macOS Catalina 10.15.1 not working.

marlone36 gravatar imagemarlone36 ( 2019-11-19 23:00:51 +0200 )edit

Hello @Ratslinger and @marlone36,

Something else I did in my home computer was I added the following extensions to Libreoffice:

  • gDriveOOo

"This should definitely not be needed as it becomes a security issue."

I understand, but that is how I got it back to work.

Do post your results,

daifu gravatar imagedaifu ( 2019-11-20 16:00:27 +0200 )edit

@daifu,

Unfortunately to me this is not worth any further effort. One issue is definitely security. Second, if wanted, can do this with Gnome on-line accounts and provide a more secure access. Can also get access to another cloud service with DropBox. Unless LO is fixed, can't see benefit of band-aid implemented solutions.

Ratslinger gravatar imageRatslinger ( 2019-11-20 18:16:37 +0200 )edit

@daifu,

One further comment regarding gDriveOOo. Did try this a while back only to find many problems with it. Even if there are enhancements since, I was not happy with the change to the file menus in LO. Also, for me, it worked once and stopped. Tried fixing and simply gave up as not being worth while.

Ratslinger gravatar imageRatslinger ( 2019-11-20 19:01:33 +0200 )edit

Well guys, back to square 1. While it worked for a few days it stopped working. Seems something else has changed. Updating to the latest Libreoffice version use to help, but not this time.

daifu gravatar imagedaifu ( 2019-12-23 20:40:38 +0200 )edit

Hello guys,

I found a very interesting piece of software. Take a look at this:

https://rclone.org/

I will post my findings,

Regards

daifu gravatar imagedaifu ( 2020-02-14 15:49:14 +0200 )edit

Same problem here. Tried using the 6 digit code from my authenticator, doesn't work. Tried an app specific password generated from my google account, doesn't work.

bkarlan gravatar imagebkarlan ( 2020-05-25 06:08:32 +0200 )edit
0

answered 2020-05-21 03:04:19 +0200

I looked for that answer too, but if you are using Linux, Ubuntu specifically, connect to a google account and create a volume of your google drive on your machine and synchronize with your google driver (cloud). When saving or opening, just put in the address bar "google: // and your email". For me it worked.

edit flag offensive delete link more
0

answered 2019-08-24 00:01:31 +0200

Opaque gravatar image

updated 2019-08-24 00:35:08 +0200

Hello,

from my perspective this doesn't work at all due to bug #tdf101630, which states that support for Google 2-Factor Authentication in LibreOffice is broken (besides that it seems a bit unclear to users that 2-Factor Authentication must be enabled in Google account first to get that 6-digit PIN on Login),

edit flag offensive delete link more

Comments

HI,

Thanks for the information.

But I have a enable the Google 2-Factor Authentication.

No working in LibreOffice yet.

I have pin bit not working in LibreOffice.

marlone36 gravatar imagemarlone36 ( 2019-08-24 23:25:20 +0200 )edit
1

@marlone36,

Google Remote has not worked for some time in LO - with or without 2FA (two factor authorization). Had is working both ways some time ago but has since been broken again. Until someone volunteers to fix this, it will remain broken. Please check referenced bug report occasionally to see if any progress.

Currently, part of the problem is that a request by LO for the 6-digit pin is presented regardless if 2FA is on or off. Tested again today with it on & off. Always get LO request for pin and never a connection. In my test, Google never gets the message from LO and doesn't even send a pin - LO v6.3.0.4 on Ubuntu 18.04

Ratslinger gravatar imageRatslinger ( 2019-08-25 06:48:12 +0200 )edit

Hi Thanks for the information.

It still not working yet.

I have tried it again.

marlone36 gravatar imagemarlone36 ( 2019-08-25 22:36:51 +0200 )edit

??? From my answer and @Ratslinger's comment it should have been clear that any further attempt will grasp to nothing.

Opaque gravatar imageOpaque ( 2019-08-26 10:18:01 +0200 )edit

Thanks both help

marlone36 gravatar imagemarlone36 ( 2019-09-09 22:12:47 +0200 )edit
0

answered 2019-09-02 21:49:01 +0200

I got a solution in Case of Linux Mint and/or Gnome Filemanager. First: If you go to Internetaccounts in your systemaptions you May sign in to Google Account. So you get Google Drive mounted in your Filesystem directly (2steps autofication in google contains a Letter and 6 Digits Like G-123456) Second: now you Are able to Go to LO "load from Server" Options and you can choose Google Drive as Server. I found Out that this way Google Drive gonna bei recondized AS an SSH Host in your Linux and LO. Third: now you can save/load Files in Google Drive.

Greetings from Germany :)

edit flag offensive delete link more

Comments

Hi, Greetings from Germany,

Thanks but on the macOS OS.

marlone36 gravatar imagemarlone36 ( 2019-09-09 22:14:05 +0200 )edit

I am on macOS Catalina 10.15.1

marlone36 gravatar imagemarlone36 ( 2019-11-19 23:00:01 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-08-23 22:58:09 +0200

Seen: 1,927 times

Last updated: May 21